summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/monkeyd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/monkeyd/files')
-rw-r--r--www-servers/monkeyd/files/monkeyd-1.5.0-fix-CPPFLAGS.patch17
-rw-r--r--www-servers/monkeyd/files/monkeyd-1.5.2-use-system-jemalloc.patch157
-rw-r--r--www-servers/monkeyd/files/monkeyd.confd6
-rw-r--r--www-servers/monkeyd/files/monkeyd.initd26
4 files changed, 206 insertions, 0 deletions
diff --git a/www-servers/monkeyd/files/monkeyd-1.5.0-fix-CPPFLAGS.patch b/www-servers/monkeyd/files/monkeyd-1.5.0-fix-CPPFLAGS.patch
new file mode 100644
index 000000000000..9e88bc999dee
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd-1.5.0-fix-CPPFLAGS.patch
@@ -0,0 +1,17 @@
+diff -Naur monkey-1.5.0.orig/plugins/auth/tools/Makefile.in monkey-1.5.0/plugins/auth/tools/Makefile.in
+--- monkey-1.5.0.orig/plugins/auth/tools/Makefile.in 2014-05-25 19:12:44.000000000 -0400
++++ monkey-1.5.0/plugins/auth/tools/Makefile.in 2014-05-26 13:15:29.347727637 -0400
+@@ -3,10 +3,11 @@
+
+ CC = @echo " CC $(_PATH)/$@"; $CC
+ CC_QUIET= @echo -n; $CC
+-CFLAGS = -I../../../src/include -I../ $CFLAGS
++CPPFLAGS = -I../../../src/include -I../
++CFLAGS = $CFLAGS
+ LDFLAGS = $LDFLAGS
+ SOURCES = ../sha1.c ../base64.c mk_passwd.c
+ OBJECTS = $(SOURCES:../.c=%.o)
+
+ ../../../bin/mk_passwd: $(OBJECTS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -ldl
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^ -ldl
diff --git a/www-servers/monkeyd/files/monkeyd-1.5.2-use-system-jemalloc.patch b/www-servers/monkeyd/files/monkeyd-1.5.2-use-system-jemalloc.patch
new file mode 100644
index 000000000000..a4934a4e21c1
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd-1.5.2-use-system-jemalloc.patch
@@ -0,0 +1,157 @@
+diff -Naur monkey-1.5.2.orig/configure monkey-1.5.2/configure
+--- monkey-1.5.2.orig/configure 2014-07-19 23:27:13.000000000 -0400
++++ monkey-1.5.2/configure 2014-07-26 10:07:08.808171546 -0400
+@@ -193,7 +193,7 @@
+
+ echo "+ Creating src/Makefile"
+ create_makefile2 mod_libs mod_obj make_script platform \
+- malloc_libc malloc_jemalloc
++ malloc_libc
+
+ echo "+ Creating plugins/Make.common"
+ create_plugins_make_common bindir
+@@ -210,33 +210,12 @@
+
+ echo -e "+ Creating Makefile"
+ if [ "$dir" = 0 ]; then
+- create_makefile1 bindir malloc_jemalloc
++ create_makefile1 bindir
+ else
+ create_makefile1_install prefix bindir mandir sysconfdir \
+- datadir logdir malloc_jemalloc
++ datadir logdir
+ fi
+
+- # if the memory allocator is jemalloc, lets start configuring the dependency
+- if [ $malloc_jemalloc -eq 1 ]; then
+- echo
+- echo -e "\033[1m=== Configuring Memory Allocator ===\033[0m"
+- cd deps/jemalloc
+- ./configure $JEMALLOC_OPTS \
+- --with-jemalloc-prefix=je_ \
+- --enable-cc-silence \
+- CFLAGS="-std=gnu99 -Wall -pipe -g3 -O3 -funroll-loops " \
+- LDFLAGS="" > jemalloc.config 2>&1
+- if [ $? -eq 0 ]; then
+- echo "+ Jemalloc configured"
+- else
+- cat jemalloc.config
+- echo
+- echo "check more details with: $ cat deps/jemalloc/config.log"
+- exit 1
+- fi
+- cd ../../
+- fi
+-
+ echo
+ echo -e "\033[1m=== Monkey Configuration ===\033[0m"
+ echo -e "Platform\t= $platform"
+@@ -316,12 +295,6 @@
+ # Create Makefile
+ create_makefile1()
+ {
+- if [ $malloc_jemalloc -eq 1 ]; then
+- $deps="deps/jemalloc"
+- else
+- $deps=""
+- fi
+-
+ cat > Makefile << EOF
+ # Monkey HTTP Daemon: Makefile
+ # ============================
+@@ -459,13 +432,6 @@
+
+ create_makefile1_install()
+ {
+- # memory allocator
+- if [ $malloc_jemalloc -eq 1 ]; then
+- all_deps="$all_deps jemalloc"
+- else
+- deps=""
+- fi
+-
+ # remove old data
+ rm -rf plugins.conf plugins.list
+ touch plugins.conf
+@@ -523,10 +489,6 @@
+ @\$(MAKE) -s -C plugins all
+ @echo " DONE"
+
+-jemalloc:
+- @echo " CC jemalloc [all]"
+- @\$(MAKE) -s -C deps/jemalloc
+-
+ clean:
+ @(cd src; \$(MAKE) clean)
+ @(cd plugins; \$(MAKE) clean)
+@@ -605,9 +567,7 @@
+ fi
+
+ if [ $malloc_jemalloc -eq 1 ]; then
+- extra="../deps/jemalloc/lib/libjemalloc.a"
+- extraso="-Wl,--whole-archive ../deps/jemalloc/lib/libjemalloc_pic.a -Wl,--no-whole-archive"
+- libs="$libs -lm"
++ libs="$libs -ljemalloc"
+ fi
+
+ cat > src/Makefile<<EOF
+diff -Naur monkey-1.5.2.orig/src/include/mk_memory.h monkey-1.5.2/src/include/mk_memory.h
+--- monkey-1.5.2.orig/src/include/mk_memory.h 2014-07-19 23:27:13.000000000 -0400
++++ monkey-1.5.2/src/include/mk_memory.h 2014-07-26 10:08:06.427168785 -0400
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+
+ #ifdef MALLOC_JEMALLOC
+-#include "../../deps/jemalloc/include/jemalloc/jemalloc.h"
++#include <jemalloc/jemalloc.h>
+ #endif
+
+ #include "mk_macros.h"
+@@ -43,11 +43,7 @@
+ static inline ALLOCSZ_ATTR(1)
+ void *mk_mem_malloc(const size_t size)
+ {
+-#ifdef MALLOC_JEMALLOC
+- void *aux = je_malloc(size);
+-#else
+ void *aux = malloc(size);
+-#endif
+
+ if (mk_unlikely(!aux && size)) {
+ perror("malloc");
+@@ -60,11 +56,7 @@
+ static inline ALLOCSZ_ATTR(1)
+ void *mk_mem_malloc_z(const size_t size)
+ {
+-#ifdef MALLOC_JEMALLOC
+- void *buf = je_calloc(1, size);
+-#else
+ void *buf = calloc(1, size);
+-#endif
+
+ if (mk_unlikely(!buf)) {
+ return NULL;
+@@ -76,11 +68,7 @@
+ static inline ALLOCSZ_ATTR(2)
+ void *mk_mem_realloc(void *ptr, const size_t size)
+ {
+-#ifdef MALLOC_JEMALLOC
+- void *aux = je_realloc(ptr, size);
+-#else
+ void *aux = realloc(ptr, size);
+-#endif
+
+ if (mk_unlikely(!aux && size)) {
+ perror("realloc");
+@@ -92,11 +80,7 @@
+
+ static inline void mk_mem_free(void *ptr)
+ {
+-#ifdef MALLOC_JEMALLOC
+- je_free(ptr);
+-#else
+ free(ptr);
+-#endif
+ }
+
+ void mk_mem_free(void *ptr);
diff --git a/www-servers/monkeyd/files/monkeyd.confd b/www-servers/monkeyd/files/monkeyd.confd
new file mode 100644
index 000000000000..fe725e80b9c1
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Add any additional command line arguments here
+MONKEY_ARGS=""
diff --git a/www-servers/monkeyd/files/monkeyd.initd b/www-servers/monkeyd/files/monkeyd.initd
new file mode 100644
index 000000000000..452cc934faa3
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON="/usr/bin/monkey"
+CONFFILE="/etc/monkeyd/monkey.conf"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting monkeyd"
+ start-stop-daemon --start --exec "${DAEMON}" -- "-D" "${MONKEY_ARGS}" >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monkeyd"
+ local PORT=$(awk '/^ *Port/ { print $2 }' "${CONFFILE}")
+ local PIDFILE=$(awk '/^ *PidFile/ { print $2 }' "${CONFFILE}")
+ PIDFILE="${PIDFILE}"."${PORT}"
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
+ eend $?
+}