summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-02-15 07:19:16 +0100
committerSam James <sam@gentoo.org>2021-02-16 18:39:30 +0000
commit200198d1d98b1465ab9e80320b10c44b93f893fc (patch)
tree05c29ca0c94081dab3cf4377eb6418f6495e2695 /www-servers/nginx-unit
parentapp-shells/mcfly: take maintaineship (diff)
downloadgentoo-200198d1d98b1465ab9e80320b10c44b93f893fc.tar.gz
gentoo-200198d1d98b1465ab9e80320b10c44b93f893fc.tar.bz2
gentoo-200198d1d98b1465ab9e80320b10c44b93f893fc.zip
www-servers/nginx-unit: Bump to version 1.22.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.22.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 512578b5b09f..c8a15d3575bc 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,2 +1,3 @@
DIST nginx-unit-1.20.0.tar.gz 787607 BLAKE2B 7ef0ea98b0fa2b5af591763ed67c1a92c7309c8ea91b29bfb3d3e309149f9d563ff8a3cb0f19f52d9d53f05a56c2a6f0e3c07e7b8315106911a87bc01f9d3af3 SHA512 dd68103795acbdcd87a951c92c72f3cb74b5e622eca4e687194508b55a592ac4312de3a8ff7ddb9a5df9750363b24dca9e1b48c7ef42c78aca3a18aca6a51f42
DIST nginx-unit-1.21.0.tar.gz 802826 BLAKE2B 9d0af079b84cd769b90d4735825765571a384d69fb8c6201d6ab2f943778a7ca19b408359e12a433d192aeefad9f7e8f760cde0568101858dabadfbb9b598784 SHA512 12e9e8b221ffe8014931fe46c7faa9398de6ad08bbc07e5f8e50f086e4a22419960522d33bece493e17ae544b499acb4ba29cb6cb731c0bb7fbdc6cdc44bf210
+DIST nginx-unit-1.22.0.tar.gz 824763 BLAKE2B 3ef343d62f3cfe793840c78fe18fd68ecad93170c87df1769636e8516df21901712d7e82caa5bafc3bf76231f32531cb7b0c1bdbe04706ee176a1e57526c50eb SHA512 7418e9dd86c10d64184f5a2f3e26c27bacc53b90ba35658fba6af00a57df89645c16c16b510d3e570eee6f8fdeef4ec7f92971f7231093e3da118e858ed386f5
diff --git a/www-servers/nginx-unit/nginx-unit-1.22.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.22.0.ebuild
new file mode 100644
index 000000000000..b0456d581545
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.22.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8,9})
+
+inherit flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php7-2 php7-3 php7-4"
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ php7-3? ( dev-lang/php:7.3[embed] )
+ php7-4? ( dev-lang/php:7.4[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:*
+ dev-ruby/rubygems:*
+ )
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ )
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}