summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-27 17:18:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-27 17:19:12 +0100
commit0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d (patch)
tree315376f8bd85acd5c4e3fc7930aaa34519594d6e /www-servers/pshs
parentkde-apps/kdecore-meta: Add falkon as alt. web browser (diff)
downloadgentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.tar.gz
gentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.tar.bz2
gentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.zip
www-servers/pshs: Bump to 0.3.3
Bump to new 0.3.3 release that fixes OpenSSL-1.1 compatibility (thanks, Quentin!) and linking to new libnetlink. Closes: https://bugs.gentoo.org/648910
Diffstat (limited to 'www-servers/pshs')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.3.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index 1fee06284690..ac55ff8d1227 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1 +1,2 @@
DIST pshs-0.3.2.tar.bz2 80103 BLAKE2B 884355e3cb621ce0367e3fe8f7697e68a5725e24fc4f5e977035cac1442eeecc1463cd5bccecc071d45250730a746c121d7b636a2b9db775e6ea174f1efb8406 SHA512 82eb0e0ff76ad6d5651b789ca59b654558562501f9f4b89a562773f5c60e80c6d43a86fca35a41a313952d8134b83fe6a11d1085c8c35cb9bbffd6d2a243964a
+DIST pshs-0.3.3.tar.bz2 81109 BLAKE2B c73aa8390257de4ffd616ecb08b570273075e72473a7e506a4ab4ca59a3ebf9f4c1467eabd1ef45b88d0d3422b14f55108c94d2e92222b186606b8b5cf8ab8c4 SHA512 c9c6dd854319153350a6e7ef245af8f89c0d50f783507211a34994d375f2ae442b22959e4a2fb1bcc02f976a8ff6f41545b176a32ea70174af0850cf1eaf77d9
diff --git a/www-servers/pshs/pshs-0.3.3.ebuild b/www-servers/pshs/pshs-0.3.3.ebuild
new file mode 100644
index 000000000000..cafb509f3846
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2[-minimal]
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}