summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-20 08:39:54 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-20 09:23:18 +0200
commitfb27862b554bdc6572f812bc0194a4db38d418cb (patch)
tree30fdd69e7e618d0ddcaa651be2ce9b37f7b5ffeb /www-servers/puma/puma-3.6.0.ebuild
parentmedia-gfx/tintii: remove old (diff)
downloadgentoo-fb27862b554bdc6572f812bc0194a4db38d418cb.tar.gz
gentoo-fb27862b554bdc6572f812bc0194a4db38d418cb.tar.bz2
gentoo-fb27862b554bdc6572f812bc0194a4db38d418cb.zip
www-servers/puma: add 3.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-servers/puma/puma-3.6.0.ebuild')
-rw-r--r--www-servers/puma/puma-3.6.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/www-servers/puma/puma-3.6.0.ebuild b/www-servers/puma/puma-3.6.0.ebuild
new file mode 100644
index 000000000000..8da7e0287405
--- /dev/null
+++ b/www-servers/puma/puma-3.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="http://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack dev-ruby/minitest dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ # Avoid test failing inconsistently
+ sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+ -e 's/localhost/127.0.0.1/' test/shell/* || die
+ sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest'; gem 'test-unit'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+ einfo "Running integration tests"
+ pushd test/shell
+ sh run.sh || die
+ popd
+}