summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-11 11:16:52 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-11 11:16:52 +0100
commitd36d7fcf8d7df517ef6fc11a31a63052aae3a707 (patch)
tree43bcaa1cdba7ad4ca81d5ea07cd3c73c65781356 /www-servers/tornado/tornado-3.1.1-r1.ebuild
parentdev-python/cffi: Drop old (diff)
downloadgentoo-d36d7fcf8d7df517ef6fc11a31a63052aae3a707.tar.gz
gentoo-d36d7fcf8d7df517ef6fc11a31a63052aae3a707.tar.bz2
gentoo-d36d7fcf8d7df517ef6fc11a31a63052aae3a707.zip
www-servers/tornado: Drop versions vulnerable to CVE-2014-9720
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=549898 obsoletes Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=482494 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=487292 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=511514 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=535794 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'www-servers/tornado/tornado-3.1.1-r1.ebuild')
-rw-r--r--www-servers/tornado/tornado-3.1.1-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/www-servers/tornado/tornado-3.1.1-r1.ebuild b/www-servers/tornado/tornado-3.1.1-r1.ebuild
deleted file mode 100644
index 8a56639a6300..000000000000
--- a/www-servers/tornado/tornado-3.1.1-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="http://www.tornadoweb.org/ https://pypi.python.org/pypi/tornado"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="curl test"
-
-RDEPEND="curl? ( dev-python/pycurl[$(python_gen_usedep python2_7)] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- python_targets_python2_7? ( dev-python/twisted-names[python_targets_python2_7] )
- )
-"
-
-REQUIRED_USE="curl? ( || ( $(python_gen_useflags python2_7) ) )"
-
-PATCHES=(
- "${FILESDIR}/unittest2-import-issue-1005.patch"
- "${FILESDIR}/${P}-py2_6-tests-fix.patch"
-)
-
-python_test() {
- cd "${TMPDIR}" || die
- "${PYTHON}" -m tornado.test.runtests || die "Tests fail with ${EPYTHON}"
-}