summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /www-servers/tornado
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/tornado')
-rw-r--r--www-servers/tornado/tornado-4.4.2-r1.ebuild1
-rw-r--r--www-servers/tornado/tornado-4.5.1.ebuild1
-rw-r--r--www-servers/tornado/tornado-4.5.3.ebuild1
-rw-r--r--www-servers/tornado/tornado-5.0.2.ebuild1
-rw-r--r--www-servers/tornado/tornado-5.1.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/www-servers/tornado/tornado-4.4.2-r1.ebuild b/www-servers/tornado/tornado-4.4.2-r1.ebuild
index 3d603a22ae1d..b03ef4435a9a 100644
--- a/www-servers/tornado/tornado-4.4.2-r1.ebuild
+++ b/www-servers/tornado/tornado-4.4.2-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-4.5.1.ebuild b/www-servers/tornado/tornado-4.5.1.ebuild
index df6e808e25cc..d4bb99a886e1 100644
--- a/www-servers/tornado/tornado-4.5.1.ebuild
+++ b/www-servers/tornado/tornado-4.5.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-4.5.3.ebuild b/www-servers/tornado/tornado-4.5.3.ebuild
index 206e059e0de9..1deec81f52bb 100644
--- a/www-servers/tornado/tornado-4.5.3.ebuild
+++ b/www-servers/tornado/tornado-4.5.3.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-5.0.2.ebuild b/www-servers/tornado/tornado-5.0.2.ebuild
index 98921c38ee75..689b47f22e8d 100644
--- a/www-servers/tornado/tornado-5.0.2.ebuild
+++ b/www-servers/tornado/tornado-5.0.2.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
diff --git a/www-servers/tornado/tornado-5.1.ebuild b/www-servers/tornado/tornado-5.1.ebuild
index cf30654f3573..8d4759b7d535 100644
--- a/www-servers/tornado/tornado-5.1.ebuild
+++ b/www-servers/tornado/tornado-5.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')