summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-06-04 10:22:28 +0200
committerHans de Graaff <graaff@gentoo.org>2021-06-04 10:22:36 +0200
commit0cba2a579e179af2c7225479422a6aab244889d3 (patch)
tree8592db8234a905a400cb0529161ac241800b0738 /www-servers
parentwww-servers/puma: cleanup (diff)
downloadgentoo-0cba2a579e179af2c7225479422a6aab244889d3.tar.gz
gentoo-0cba2a579e179af2c7225479422a6aab244889d3.tar.bz2
gentoo-0cba2a579e179af2c7225479422a6aab244889d3.zip
www-servers/puma: cleanup
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-3.12.5-r1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 7e5c3e282674..dba3a54e8180 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,3 +1,2 @@
-DIST puma-3.12.5.tar.gz 219175 BLAKE2B 55e80fba8fd84004090cb8d30b6fd01652f1beb1d1216c5d41ce46c616677504fa867f9701ed2631f4edc956c9377d72c6fd4a1b61e99fdbb50ea371b170a0c0 SHA512 1e6721844cbabab0cfb8b1707625723061821dae3ee06a3330075f787ae580e6836d9cbe436e63dc4602253ad1da3b56135316c923c03bbbae454d9457a44aec
DIST puma-5.1.1.tar.gz 284807 BLAKE2B 59ba17129e55e79aa2f8092d60a5643840bd996b7832d421cb72538fc48b0fb302353bedef56cc9b115bdfb15b33b0f453bfbf759b2e9552a9490a8b0cef3090 SHA512 8653c622c21dca2116219702e801d7aa3272f0771fd5c2d5149927edbd504a9838fb0d442bfc5dc523035a94dad25946738a5dda954fdaa74a9a00c85ed9f86e
DIST puma-5.3.2.tar.gz 297673 BLAKE2B e3bfa38347526063587db966d20ea68f32cd88616d89b5f2d9152228d5d420b50c2918e24304c1bc8119af5790a2464f0a055ab92862a56262013ddbba006a1f SHA512 32e80b413184d371d451a35985a371a7655df0f7e81624f2a05e3cf65c2e1b035275a8e25ab03d13c9c1f921ec30cdeb3659e1201baae5940dcb3edcb525ff25
diff --git a/www-servers/puma/puma-3.12.5-r1.ebuild b/www-servers/puma/puma-3.12.5-r1.ebuild
deleted file mode 100644
index 063d1408eda7..000000000000
--- a/www-servers/puma/puma-3.12.5-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
-HOMEPAGE="https://puma.io/"
-SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
-IUSE=""
-
-DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
-RDEPEND+=" dev-libs/openssl:0"
-
-ruby_add_bdepend "virtual/ruby-ssl
- test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
-
-all_ruby_prepare() {
- eapply "${FILESDIR}/${PN}-3.12.1-ruby26-waitpid.patch"
- eapply "${FILESDIR}/${PN}-3.12.5-cve-2020-11077.patch"
-
- sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
-
- # Avoid test failing inconsistently
- sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
-
- # Fix FORWARDED_PROTO
- sed -i -e '127 s/443/80/' test/test_puma_server.rb || die
-
- # Avoid test that trigger a bug in ruby very easily and lead to
- # failure. This affects all current puma versions in combination
- # with the latest ruby versions, so we add this new version anyway
- # while allowing these tests to fail.
- # https://github.com/puma/puma/pull/1345
- rm -f test/test_puma_server_ssl.rb || die
-
- # Use correct ruby version
- sed -i -e 's/ruby -rrubygems/#{Gem.ruby} -rrubygems/' test/shell/t{1,3}.rb || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
- -e 's/localhost/127.0.0.1/' test/shell/* || die
- sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/puma_http11 extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/puma_http11
- cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
-}
-
-each_ruby_test() {
- einfo "Running test suite"
- ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
-
- einfo "Running integration tests"
- pushd test/shell
- #sh run.sh || die
- popd
-}