summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-12-02 17:56:47 -0500
committerMike Pagano <mpagano@gentoo.org>2021-12-02 17:56:47 -0500
commit0d32e5442be349c89921d5989e9b636d3f50d281 (patch)
tree1eea119630afb70fcf779ab0eda21c2fd9135091 /www-servers
parentnet-misc/ntpsec: Remove vulnerable 1.2.0 (diff)
downloadgentoo-0d32e5442be349c89921d5989e9b636d3f50d281.tar.gz
gentoo-0d32e5442be349c89921d5989e9b636d3f50d281.tar.bz2
gentoo-0d32e5442be349c89921d5989e9b636d3f50d281.zip
www-servers/nginx-unit: Version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/Manifest2
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.25.0-r1.ebuild91
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.26.1.ebuild (renamed from www-servers/nginx-unit/nginx-unit-1.25.0-r2.ebuild)2
3 files changed, 1 insertions, 94 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index e726a2a0c0a2..2d11205ebdc0 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,3 +1,3 @@
DIST nginx-unit-1.22.0.tar.gz 824763 BLAKE2B 3ef343d62f3cfe793840c78fe18fd68ecad93170c87df1769636e8516df21901712d7e82caa5bafc3bf76231f32531cb7b0c1bdbe04706ee176a1e57526c50eb SHA512 7418e9dd86c10d64184f5a2f3e26c27bacc53b90ba35658fba6af00a57df89645c16c16b510d3e570eee6f8fdeef4ec7f92971f7231093e3da118e858ed386f5
-DIST nginx-unit-1.25.0.tar.gz 853280 BLAKE2B 7aa33e687ba754ebaaca4a0076df3f1cc05e83213de1b64cf28718bf53b9085a26a78c036f4e98308cabec0026ce2b4e91718dfb9d8d83fdad779a587e1c1d71 SHA512 fc001ab21c5aa6c07b092f7b1f44be3b88636f9e2059c8bc4049a06d863daae1bbfa2531a4a24bdd5976250d7a0e260dcf0dbb0dec63efcc008b5398c6bb4bbd
DIST nginx-unit-1.26.0.tar.gz 865556 BLAKE2B 8ef2f32364ae9858ec41c21639c2b9514d7aed4d4150d2952634946b0b180f5fee7c4be6e67e3608040d9bc7bd0f4fd19c158b5457fe629566bc42ff845f599b SHA512 9e10cd320bc6182e94f8b5296367922b39e2149166793f46c5012f9dbba806a4508ee4ec65a8677391f5c4d7b06481c176ccf94b8fd1ab5d4b018eb167877f5f
+DIST nginx-unit-1.26.1.tar.gz 865811 BLAKE2B eb0b62e48a8d0f9199dfe77a2d6ec90a06ac24f83b362ae16fde83eea53e03923127be7b24da47a83cf51fc4ebe7930cba9a3ee7550a5243f242cc4bfba3a3b9 SHA512 1caadb35cb208067a5d437e1f649c9f9a833a39c4344b2c3a5ae94d9fcd811913e2f23114cf8d7886030306e036da18c55f09044b8a575c1616568321b8d84ec
diff --git a/www-servers/nginx-unit/nginx-unit-1.25.0-r1.ebuild b/www-servers/nginx-unit/nginx-unit-1.25.0-r1.ebuild
deleted file mode 100644
index b4fa47193ab9..000000000000
--- a/www-servers/nginx-unit/nginx-unit-1.25.0-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit flag-o-matic python-single-r1 systemd toolchain-funcs
-
-MY_P="unit-${PV}"
-DESCRIPTION="Dynamic web and application server"
-HOMEPAGE="https://unit.nginx.org"
-SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-MY_USE="perl python ruby"
-MY_USE_PHP="php7-3 php7-4"
-IUSE="${MY_USE} ${MY_USE_PHP} ssl"
-REQUIRED_USE="|| ( ${IUSE} )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="perl? ( dev-lang/perl:= )
- php7-3? ( dev-lang/php:7.3[embed] )
- php7-4? ( dev-lang/php:7.4[embed] )
- python? ( ${PYTHON_DEPS} )
- ruby? (
- dev-lang/ruby:*
- dev-ruby/rubygems:*
- )
- ssl? ( dev-libs/openssl:0= )
- virtual/libcrypt:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-glibc-2.34.patch )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- eapply_user
- sed -i '/^CFLAGS/d' auto/make || die
- default
-}
-
-src_configure() {
- local opt=(
- --control=unix:/run/${PN}.sock
- --log=/var/log/${PN}
- --modules=$(get_libdir)/${PN}
- --pid=/run/${PN}.pid
- --prefix=/usr
- --state=/var/lib/${PN}
- )
-
- use ssl && opt+=( --openssl )
- export AR="$(tc-getAR)"
- export CC="$(tc-getCC)"
- ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
-
- # Modules require position-independent code
- append-cflags $(test-flags-CC -fPIC)
-
- for flag in ${MY_USE} ; do
- if use ${flag} ; then
- ./configure ${flag} || die "Module configuration failed: ${flag}"
- fi
- done
-
- for flag in ${MY_USE_PHP} ; do
- if use ${flag} ; then
- local php_slot="/usr/$(get_libdir)/${flag/-/.}"
- ./configure php \
- --module=${flag} \
- --config=${php_slot}/bin/php-config \
- --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
- fi
- done
-}
-
-src_install() {
- default
-
- diropts -m 0770
- keepdir /var/lib/${PN}
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
-}
diff --git a/www-servers/nginx-unit/nginx-unit-1.25.0-r2.ebuild b/www-servers/nginx-unit/nginx-unit-1.26.1.ebuild
index 1d9e098f0bcb..dcbeae43d4de 100644
--- a/www-servers/nginx-unit/nginx-unit-1.25.0-r2.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.26.1.ebuild
@@ -34,8 +34,6 @@ DEPEND="perl? ( dev-lang/perl:= )
virtual/libcrypt:0="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-glibc-2.34.patch )
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}