summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-01-09 22:16:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-01-09 22:16:21 +0900
commit50241a31053044e4ab827f1f1193351891427d2c (patch)
tree7c2f5fd9ac5b8880283ea83ba48f3144ec2345f4 /www-servers
parentprofiles: remove fam from desktop profiles & unmask on glib (diff)
downloadgentoo-50241a31053044e4ab827f1f1193351891427d2c.tar.gz
gentoo-50241a31053044e4ab827f1f1193351891427d2c.tar.bz2
gentoo-50241a31053044e4ab827f1f1193351891427d2c.zip
www-servers/h2o: add libh2o USE flag
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/h2o/h2o-2.2.5.ebuild9
-rw-r--r--www-servers/h2o/h2o-2.2.6.ebuild9
-rw-r--r--www-servers/h2o/h2o-9999.ebuild9
-rw-r--r--www-servers/h2o/metadata.xml1
4 files changed, 19 insertions, 9 deletions
diff --git a/www-servers/h2o/h2o-2.2.5.ebuild b/www-servers/h2o/h2o-2.2.5.ebuild
index afa121fe12a7..090cb8025bb1 100644
--- a/www-servers/h2o/h2o-2.2.5.ebuild
+++ b/www-servers/h2o/h2o-2.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -15,13 +15,15 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="libressl +mruby"
+IUSE="libh2o libressl +mruby"
RDEPEND="dev-lang/perl
sys-libs/zlib
+ libh2o? ( dev-libs/libuv )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
+ libh2o? ( virtual/pkgconfig )
mruby? (
${RUBY_DEPS}
|| (
@@ -71,7 +73,8 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/${PN}
-DWITH_MRUBY=$(usex mruby)
- -DWITHOUT_LIBS=ON
+ -DWITHOUT_LIBS=$(usex !libh2o)
+ -DBUILD_SHARED_LIBS=$(usex libh2o)
)
cmake-utils_src_configure
}
diff --git a/www-servers/h2o/h2o-2.2.6.ebuild b/www-servers/h2o/h2o-2.2.6.ebuild
index 586600774979..b059185c8fb4 100644
--- a/www-servers/h2o/h2o-2.2.6.ebuild
+++ b/www-servers/h2o/h2o-2.2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -15,13 +15,15 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="libressl +mruby"
+IUSE="libh2o libressl +mruby"
RDEPEND="dev-lang/perl
sys-libs/zlib
+ libh2o? ( dev-libs/libuv )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
+ libh2o? ( virtual/pkgconfig )
mruby? (
${RUBY_DEPS}
|| (
@@ -71,7 +73,8 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/${PN}
-DWITH_MRUBY=$(usex mruby)
- -DWITHOUT_LIBS=ON
+ -DWITHOUT_LIBS=$(usex !libh2o)
+ -DBUILD_SHARED_LIBS=$(usex libh2o)
)
cmake-utils_src_configure
}
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index 54be51dba8fc..473f4d671cbf 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -15,13 +15,15 @@ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="libressl +mruby"
+IUSE="libh2o libressl +mruby"
RDEPEND="dev-lang/perl
sys-libs/zlib
+ libh2o? ( dev-libs/libuv )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
+ libh2o? ( virtual/pkgconfig )
mruby? (
${RUBY_DEPS}
|| (
@@ -68,7 +70,8 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/${PN}
-DWITH_MRUBY=$(usex mruby)
- -DWITHOUT_LIBS=ON
+ -DWITHOUT_LIBS=$(usex !libh2o)
+ -DBUILD_SHARED_LIBS=$(usex libh2o)
)
cmake-utils_src_configure
}
diff --git a/www-servers/h2o/metadata.xml b/www-servers/h2o/metadata.xml
index 6a34529b48f0..dab1128615a0 100644
--- a/www-servers/h2o/metadata.xml
+++ b/www-servers/h2o/metadata.xml
@@ -11,6 +11,7 @@
when compared to older generations of HTTP servers.
</longdescription>
<use>
+ <flag name="libh2o">Build and install libh2o</flag>
<flag name="mruby">Enable support for mruby</flag>
</use>
<upstream>