summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-19 10:11:37 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-19 10:30:42 +0200
commit54f3e4c051afc4567366f81565735a18fc7bacca (patch)
tree264ad3ff31ff0c7ffb2b95a1781c9a0b499ee266 /www-servers
parentdev-python/async_generator: Fix conftest.py ImportMismatchError (diff)
downloadgentoo-54f3e4c051afc4567366f81565735a18fc7bacca.tar.gz
gentoo-54f3e4c051afc4567366f81565735a18fc7bacca.tar.bz2
gentoo-54f3e4c051afc4567366f81565735a18fc7bacca.zip
www-servers/puma: add 3.12.5
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-3.12.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index cfbf63a3762c..25b951057616 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,2 +1,3 @@
DIST puma-3.12.4.tar.gz 219148 BLAKE2B d9fcef62474a1522c29f13fb2572c99bd6d4217bc94febb9c4fe6e699808ad0002fcd88dfd16884a5a9c7296e4d6dd08bc50ce7278f41608678feb18e3a034b4 SHA512 302505512b04c68f9794461b0e7693cd3ff4dfb325b18e50f0f659649c7f504f55765437382557c65bce45d32a1710ab16a875d1fc6d143d4ca297d2b2333108
+DIST puma-3.12.5.tar.gz 219175 BLAKE2B 55e80fba8fd84004090cb8d30b6fd01652f1beb1d1216c5d41ce46c616677504fa867f9701ed2631f4edc956c9377d72c6fd4a1b61e99fdbb50ea371b170a0c0 SHA512 1e6721844cbabab0cfb8b1707625723061821dae3ee06a3330075f787ae580e6836d9cbe436e63dc4602253ad1da3b56135316c923c03bbbae454d9457a44aec
DIST puma-4.3.3.tar.gz 241756 BLAKE2B a6ff66a449bf04110b4a6e9bdaa740f1144076290f1733922ecab45b5b7e6115ee1f7431b280401adb866838b539b943a35a5955f6d7cf51075941e05451e655 SHA512 1ee81c8d144466a75d5110fd3545527c36af51d2e191c171a985944206524c10a2b4e35fb535e2a1a0a3af5d460a7071ceb9233fae8dc81784643c6b9dc06e6e
diff --git a/www-servers/puma/puma-3.12.5.ebuild b/www-servers/puma/puma-3.12.5.ebuild
new file mode 100644
index 000000000000..0fd015b17d87
--- /dev/null
+++ b/www-servers/puma/puma-3.12.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/${PN}-3.12.1-ruby26-waitpid.patch"
+
+ sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ # Avoid test failing inconsistently
+ sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
+
+ # Avoid test that trigger a bug in ruby very easily and lead to
+ # failure. This affects all current puma versions in combination
+ # with the latest ruby versions, so we add this new version anyway
+ # while allowing these tests to fail.
+ # https://github.com/puma/puma/pull/1345
+ rm -f test/test_puma_server_ssl.rb || die
+
+ # Use correct ruby version
+ sed -i -e 's/ruby -rrubygems/#{Gem.ruby} -rrubygems/' test/shell/t{1,3}.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+ -e 's/localhost/127.0.0.1/' test/shell/* || die
+ sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+ einfo "Running integration tests"
+ pushd test/shell
+ #sh run.sh || die
+ popd
+}