summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-13 20:45:05 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-13 21:02:59 -0400
commit66e00955bd8dd37e04c5d1c6febb50fe84b2c7e8 (patch)
tree612e34dca1a61d225c8bb91f24790c5b6c85c9c2 /www-servers
parentdev-java/exolab{core,tools}: Removal from the tree. Fixes bug 220287. (diff)
downloadgentoo-66e00955bd8dd37e04c5d1c6febb50fe84b2c7e8.tar.gz
gentoo-66e00955bd8dd37e04c5d1c6febb50fe84b2c7e8.tar.bz2
gentoo-66e00955bd8dd37e04c5d1c6febb50fe84b2c7e8.zip
www-servers/monkeyd: fix build on uClibc
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild b/www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild
index e265962791f5..d07b3b808783 100644
--- a/www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit toolchain-funcs depend.php multilib
+inherit flag-o-matic toolchain-funcs multilib
MY_P="${PN/d}-${PV}"
DESCRIPTION="A small, fast, and scalable web server"
@@ -86,6 +86,13 @@ src_configure() {
myconf+=" --static-plugins=${enable_plugins%,}"
fi
+ # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
+ # but shouldn't because it is POSIX. This needs to be fixed
+ # in uClibc. Also, we really should us append-cppflags but
+ # monkey's build system doesn't respect CPPFLAGS. This needs
+ # to be fixed in monkey.
+ use elibc_uclibc && append-cflags -D_GNU_SOURCE
+
# Non-autotools configure
./configure \
--pthread-tls \