summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-09 08:11:38 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-10 06:33:50 +0200
commit72405c639f41fc40584a120196a87e502f46d199 (patch)
tree36fb296d29cb198c6b810bb9dd4e07b4a739c58b /www-servers
parentwww-servers/puma: cleanup (diff)
downloadgentoo-72405c639f41fc40584a120196a87e502f46d199.tar.gz
gentoo-72405c639f41fc40584a120196a87e502f46d199.tar.bz2
gentoo-72405c639f41fc40584a120196a87e502f46d199.zip
www-servers/puma: add 5.3.0
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-5.3.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 880e502e1ab4..cfd7a1449e40 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,3 +1,4 @@
DIST puma-3.12.5.tar.gz 219175 BLAKE2B 55e80fba8fd84004090cb8d30b6fd01652f1beb1d1216c5d41ce46c616677504fa867f9701ed2631f4edc956c9377d72c6fd4a1b61e99fdbb50ea371b170a0c0 SHA512 1e6721844cbabab0cfb8b1707625723061821dae3ee06a3330075f787ae580e6836d9cbe436e63dc4602253ad1da3b56135316c923c03bbbae454d9457a44aec
DIST puma-5.1.1.tar.gz 284807 BLAKE2B 59ba17129e55e79aa2f8092d60a5643840bd996b7832d421cb72538fc48b0fb302353bedef56cc9b115bdfb15b33b0f453bfbf759b2e9552a9490a8b0cef3090 SHA512 8653c622c21dca2116219702e801d7aa3272f0771fd5c2d5149927edbd504a9838fb0d442bfc5dc523035a94dad25946738a5dda954fdaa74a9a00c85ed9f86e
DIST puma-5.2.2.tar.gz 293551 BLAKE2B ba7ba9d8a2dcf9ea9716624f712d6b569472e8bfd8d7501a5807007ccdc6b6b36a8fc6f65f47f5898907adb3d3b85e2630194d5527c96ed655ce6a52192ec36a SHA512 b2d4f711cd1ad4f4557991ba26d7b940573b413e6a4c589d8447e78135d8d47e7222de4c865919981b677891cb2b57e3a3cf015d1f9a637b671f4f221c7ea77f
+DIST puma-5.3.0.tar.gz 297273 BLAKE2B c8377b32a0bcdc175f043327d09e107cc2bbc4fd8f38eaf7015da7b0f715cff304c0ee5b9913e19bbf63aa9e4319ee8bce19d01e3439b2a492fff69fea5f7b15 SHA512 00d41e2549911233d3c9744610bd557803ad049f85c180d0ddd88e6f01352d4f79e728b12cd335cb38f9c56e969644bccafa82b8cce0b8f91b677333e53d9584
diff --git a/www-servers/puma/puma-5.3.0.ebuild b/www-servers/puma/puma-5.3.0.ebuild
new file mode 100644
index 000000000000..5d0f1ef44559
--- /dev/null
+++ b/www-servers/puma/puma-5.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+}