summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-12-12 15:20:00 -0500
committerMike Gilbert <floppym@gentoo.org>2016-12-12 15:21:00 -0500
commit9301cbd868a978f9e4024c91a079d04c17028153 (patch)
treeb9d3feba99eff3e2f52f2076d62960ef56c02280 /www-servers
parentwww-servers/uwsgi: drop unused distutils-r1 (diff)
downloadgentoo-9301cbd868a978f9e4024c91a079d04c17028153.tar.gz
gentoo-9301cbd868a978f9e4024c91a079d04c17028153.tar.bz2
gentoo-9301cbd868a978f9e4024c91a079d04c17028153.zip
www-servers/uwsgi: fix build with php5.6
Bug: https://bugs.gentoo.org/598730 Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/uwsgi/files/2.0.14-php-plugin.patch22
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.14.ebuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/www-servers/uwsgi/files/2.0.14-php-plugin.patch b/www-servers/uwsgi/files/2.0.14-php-plugin.patch
new file mode 100644
index 000000000000..f60a6553cfd1
--- /dev/null
+++ b/www-servers/uwsgi/files/2.0.14-php-plugin.patch
@@ -0,0 +1,22 @@
+From 6b332e6f7e6fc3c267a91ce5b5591684575ea271 Mon Sep 17 00:00:00 2001
+From: Damjan Georgievski <gdamjan@gmail.com>
+Date: Thu, 13 Oct 2016 00:55:35 +0200
+Subject: [PATCH] fix issue #1380 - compiling with llvm/freebsd
+
+---
+ plugins/php/php_plugin.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/php/php_plugin.c b/plugins/php/php_plugin.c
+index 536ec1a..ef30180 100644
+--- a/plugins/php/php_plugin.c
++++ b/plugins/php/php_plugin.c
+@@ -232,7 +232,7 @@ static void sapi_uwsgi_register_variables(zval *track_vars_array TSRMLS_DC)
+ size_t name_len = equal-usl->value;
+ char *name = estrndup(usl->value, name_len);
+ char *strval = equal+1;
+- zend_register_string_constant(name, name_len, strval, CONST_CS, 0);
++ zend_register_string_constant(name, name_len, strval, CONST_CS, 0 TSRMLS_CC);
+ }
+ usl = usl->next;
+ }
diff --git a/www-servers/uwsgi/uwsgi-2.0.14.ebuild b/www-servers/uwsgi/uwsgi-2.0.14.ebuild
index f54848bc781b..404a756c4da3 100644
--- a/www-servers/uwsgi/uwsgi-2.0.14.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.14.ebuild
@@ -144,6 +144,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/2.0.14-php-plugin.patch"
+
sed -i \
-e "s|'-O2', ||" \
-e "s|'-Werror', ||" \