summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-07-26 14:06:00 -0400
committerZac Medico <zmedico@gentoo.org>2020-07-26 17:06:00 -0700
commitfc7e00f0413548a07650f8467f293c2a8cb996a8 (patch)
treef43dc6a2e8ce2b1a767ff52d263b45f319021485 /www-servers
parentmedia-sound/wavpack: security cleanup (diff)
downloadgentoo-fc7e00f0413548a07650f8467f293c2a8cb996a8.tar.gz
gentoo-fc7e00f0413548a07650f8467f293c2a8cb996a8.tar.bz2
gentoo-fc7e00f0413548a07650f8467f293c2a8cb996a8.zip
www-servers/civetweb: Version bump to 1.12
Closes: https://bugs.gentoo.org/733980 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/civetweb/Manifest1
-rw-r--r--www-servers/civetweb/civetweb-1.12.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
index 8d85e5896858..b10a725710a2 100644
--- a/www-servers/civetweb/Manifest
+++ b/www-servers/civetweb/Manifest
@@ -1 +1,2 @@
DIST civetweb-1.11.tar.gz 11421650 BLAKE2B 487044a313c2ff005a8dfa247b3d8a3c3b52ef048cbc3050ec8c0402ccef4e12e28de53fed5a3a91df1e7f59ba6c03bf545413ffdd0ce3e4d604148c16c661e9 SHA512 e1520fd2f4a54b6ab4838f4da2ce3f0956e9884059467d196078935a3fce61dad619f3bb1bc2b4c6a757e1a8abfed0e83cba38957c7c52fff235676e9dd1d428
+DIST civetweb-1.12.tar.gz 11463079 BLAKE2B 1182f798a2f9cdb34754b3c0edf80160efda31f72d800b26b27ec36ff4a5623745495a52632a128aefda67c6b902250c4e01ec7debd73d4a95abfc42a1b17ea6 SHA512 d6f8d29011bc1accd5384856bef16c0f20305f622a8f8c127cdf3ae5c567db3aba0d76293cc8c77f90f4989c44b2896a45e533d2f2408cc49488d1d234d308f5
diff --git a/www-servers/civetweb/civetweb-1.12.ebuild b/www-servers/civetweb/civetweb-1.12.ebuild
new file mode 100644
index 000000000000..f5dc3264ac3f
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx +server ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_BUILD_TESTING=OFF
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
+ -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake_src_configure
+}