summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-30 16:16:05 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-30 16:16:05 +0900
commitfcd7b5fb1745e190b4f223df95dc88b2b1879e29 (patch)
tree959c0ba1a2bb4da7f6d67f86fa407251454a867e /www-servers
parentwww-servers/h2o: update USE_RUBY (diff)
downloadgentoo-fcd7b5fb1745e190b4f223df95dc88b2b1879e29.tar.gz
gentoo-fcd7b5fb1745e190b4f223df95dc88b2b1879e29.tar.bz2
gentoo-fcd7b5fb1745e190b4f223df95dc88b2b1879e29.zip
www-servers/h2o: update to EAPI 8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/h2o/h2o-2.2.6-r1.ebuild21
-rw-r--r--www-servers/h2o/h2o-9999.ebuild20
2 files changed, 16 insertions, 25 deletions
diff --git a/www-servers/h2o/h2o-2.2.6-r1.ebuild b/www-servers/h2o/h2o-2.2.6-r1.ebuild
index a1e7854aebf1..2fdec9f496f3 100644
--- a/www-servers/h2o/h2o-2.2.6-r1.ebuild
+++ b/www-servers/h2o/h2o-2.2.6-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
+EAPI="8"
CMAKE_MAKEFILE_GENERATOR="emake"
SSL_DEPS_SKIP=1
USE_RUBY="ruby26 ruby27"
@@ -18,28 +17,26 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="libh2o +mruby"
-RDEPEND="
- acct-group/h2o
+RDEPEND="acct-group/h2o
acct-user/h2o
dev-lang/perl
+ !sci-libs/libh2o
sys-libs/zlib
libh2o? ( dev-libs/libuv )
- dev-libs/openssl:0=
-"
-DEPEND="
- ${RDEPEND}
- libh2o? ( virtual/pkgconfig )
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
mruby? (
${RUBY_DEPS}
|| (
dev-libs/onigmo
dev-libs/oniguruma
)
+ )"
+BDEPEND="libh2o? ( virtual/pkgconfig )
+ mruby? (
sys-devel/bison
virtual/pkgconfig
- )
-"
-RDEPEND+="!sci-libs/libh2o"
+ )"
PATCHES=( "${FILESDIR}"/${PN}-2.2-mruby.patch )
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index 9ea1b75fb86b..cd6fd817fc38 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
+EAPI="8"
CMAKE_MAKEFILE_GENERATOR="emake"
SSL_DEPS_SKIP=1
USE_RUBY="ruby26 ruby27"
inherit cmake git-r3 ruby-single ssl-cert systemd toolchain-funcs
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE="libh2o +mruby"
-RDEPEND="
- acct-group/h2o
+RDEPEND="acct-group/h2o
acct-user/h2o
dev-lang/perl
+ !sci-libs/libh2o
sys-libs/zlib
libh2o? ( dev-libs/libuv )
- dev-libs/openssl:0=
-"
-DEPEND="
- ${RDEPEND}
- libh2o? ( virtual/pkgconfig )
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
mruby? (
${RUBY_DEPS}
|| (
@@ -37,10 +32,9 @@ DEPEND="
dev-libs/oniguruma
)
sys-devel/bison
- virtual/pkgconfig
)
"
-RDEPEND+="!sci-libs/libh2o"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${PN}-2.3-mruby.patch )