summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDrew Davenport <ddavenport@chromium.org>2020-06-03 10:56:01 -0600
committerMatt Turner <mattst88@gentoo.org>2020-06-03 12:25:14 -0700
commit971f87322749c6890926e009a1eb10a6b44f562d (patch)
treefedb3a53bb31a9edf75bc46150d42a8146433092 /x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
parentmedia-libs/mesa: Add device select vulkan layer (diff)
downloadgentoo-971f87322749c6890926e009a1eb10a6b44f562d.tar.gz
gentoo-971f87322749c6890926e009a1eb10a6b44f562d.tar.bz2
gentoo-971f87322749c6890926e009a1eb10a6b44f562d.zip
x11-apps/igt-gpu-tools: Fix USE flags dependency
Test build is required for docs. Express this in REQUIRED_USE, and allow tests to be built without building docs. Signed-off-by: Drew Davenport <ddavenport@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/16057 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild')
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
index e87a5ccf4a7a..b202d340de99 100644
--- a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.25.ebuild
@@ -20,13 +20,14 @@ else
fi
LICENSE="MIT"
SLOT="0"
-IUSE="chamelium doc man overlay runner unwind valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xv"
+IUSE="chamelium doc man overlay runner tests unwind valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xv"
REQUIRED_USE="
|| ( video_cards_amdgpu video_cards_intel video_cards_nouveau )
overlay? (
video_cards_intel
|| ( X xv )
)
+ doc? ( tests )
"
RESTRICT="test"
@@ -93,7 +94,7 @@ src_configure() {
$(meson_feature man)
$(meson_feature overlay)
$(meson_feature runner)
- $(meson_feature doc tests) # Test build is required for docs
+ $(meson_feature tests)
$(meson_feature valgrind)
$(meson_feature unwind libunwind)
-Doverlay_backends=${overlay_backends%?}