summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-20 15:06:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-20 15:08:44 +0200
commit2889250af852e491b4718ccc552a435205ca54f5 (patch)
tree3c9b3a73667508f43af40a47283d17fd8902c328 /x11-apps/radeon-profile-daemon
parentpackage.mask: Last rite sci-biology/cufflinks (diff)
downloadgentoo-2889250af852e491b4718ccc552a435205ca54f5.tar.gz
gentoo-2889250af852e491b4718ccc552a435205ca54f5.tar.bz2
gentoo-2889250af852e491b4718ccc552a435205ca54f5.zip
x11-apps/radeon-profile-daemon: Initial commit
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-apps/radeon-profile-daemon')
-rw-r--r--x11-apps/radeon-profile-daemon/Manifest1
-rw-r--r--x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd9
-rw-r--r--x11-apps/radeon-profile-daemon/metadata.xml11
-rw-r--r--x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309.ebuild40
-rw-r--r--x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild40
5 files changed, 101 insertions, 0 deletions
diff --git a/x11-apps/radeon-profile-daemon/Manifest b/x11-apps/radeon-profile-daemon/Manifest
new file mode 100644
index 000000000000..636a758f2f60
--- /dev/null
+++ b/x11-apps/radeon-profile-daemon/Manifest
@@ -0,0 +1 @@
+DIST radeon-profile-daemon-20190309.tar.gz 12178 BLAKE2B 931ce4bb123456e349a68c8fe0b18150ff988a83a5e58cf451f68025240a8b4c802e03a567ef41684e91442bf21c02cc00d31ef6c82a67ca7eb7587754c6f32e SHA512 f2bb6f7dc0bf322e5c43c5ca1f99501a4fd3f4532cc9c1686b5cfbc58bdd423e81c25d3ae03fcae9dc15dc92d8ad089b2357b27b0ff399de7ac27213e00b2f37
diff --git a/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd b/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd
new file mode 100644
index 000000000000..e4e7afb04c5c
--- /dev/null
+++ b/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Daemon for radeon-profile GUI"
+
+command="/usr/sbin/radeon-profile-daemon"
+command_background="true"
+pidfile="/run/${SVCNAME}.pid"
diff --git a/x11-apps/radeon-profile-daemon/metadata.xml b/x11-apps/radeon-profile-daemon/metadata.xml
new file mode 100644
index 000000000000..1b9303f07e95
--- /dev/null
+++ b/x11-apps/radeon-profile-daemon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">marazmista/radeon-profile-daemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309.ebuild b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309.ebuild
new file mode 100644
index 000000000000..052a3ef3b330
--- /dev/null
+++ b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils systemd
+
+DESCRIPTION="Daemon for radeon-profile GUI"
+HOMEPAGE="https://github.com/marazmista/radeon-profile-daemon"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile-daemon.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_prepare() {
+ default
+ sed \
+ -e '/^bin\.path/s@/bin@/sbin@' \
+ -e "/^service\.path/s@=.*\$@= $(systemd_get_systemunitdir)@" \
+ -i radeon-profile-daemon.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
diff --git a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
new file mode 100644
index 000000000000..052a3ef3b330
--- /dev/null
+++ b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils systemd
+
+DESCRIPTION="Daemon for radeon-profile GUI"
+HOMEPAGE="https://github.com/marazmista/radeon-profile-daemon"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile-daemon.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_prepare() {
+ default
+ sed \
+ -e '/^bin\.path/s@/bin@/sbin@' \
+ -e "/^service\.path/s@=.*\$@= $(systemd_get_systemunitdir)@" \
+ -i radeon-profile-daemon.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}