summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-29 13:24:58 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-29 13:26:19 -0800
commitb3c3e010f395cecefcc8cd5bb7ef05a227f18336 (patch)
tree8205d22f84d77f4fbb74709cf431b3b12dc89c7a /x11-apps/xauth/xauth-1.0.10.ebuild
parentx11-apps/xauth: Depend on dev-util/cmdtest for tests. (diff)
downloadgentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.tar.gz
gentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.tar.bz2
gentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.zip
x11-apps/xauth: Version bump to 1.0.10.
Diffstat (limited to 'x11-apps/xauth/xauth-1.0.10.ebuild')
-rw-r--r--x11-apps/xauth/xauth-1.0.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-apps/xauth/xauth-1.0.10.ebuild b/x11-apps/xauth/xauth-1.0.10.ebuild
new file mode 100644
index 000000000000..102fdf1c91a9
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ipv6 test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmdtest )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}