summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-19 19:09:12 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-19 19:10:36 -0700
commit30c5f9d981024c2c5d10d8c76aa974c97b3f160b (patch)
tree80a188fd3bcda34e82acf8bfa9a74d327b27ef0e /x11-apps/xauth
parentdev-util/github-cli: add 2.8.0 (diff)
downloadgentoo-30c5f9d981024c2c5d10d8c76aa974c97b3f160b.tar.gz
gentoo-30c5f9d981024c2c5d10d8c76aa974c97b3f160b.tar.bz2
gentoo-30c5f9d981024c2c5d10d8c76aa974c97b3f160b.zip
x11-apps/xauth: Version bump to 1.1.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/Manifest1
-rw-r--r--x11-apps/xauth/xauth-1.1.2.ebuild29
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild13
3 files changed, 36 insertions, 7 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index c8c5efc19864..bf76bfdfbf58 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1 +1,2 @@
DIST xauth-1.1.1.tar.bz2 167315 BLAKE2B fbe36f867031c734e3a8ae9719145caa16828d4df156503c299812fb63f86462561ffea945f12fabc5e036cc63664ee1d8b5b37630dee8d4af6f2473aa5fcd1a SHA512 998c3158378fff50d368959c29335173b8d98e02591cb3d7b2f9534b5a44b19deb4cb7da9bf291ca5a37f69f833d72839b2c6611723306d10c1b4968ae4d4120
+DIST xauth-1.1.2.tar.xz 156960 BLAKE2B 2ba168229bdf0c1d0fdd4c352e434abfc6f527cbafce35abac8d403a0dea91f00fd858f91f177128d13a0e618d1d95061c71ef32a3e12ac91b72a257dcfcd12b SHA512 ac23fcd166b45abf7b030994ff3332c9906023dc1ddfa9b9d3000e6a914dc5e0213c4a2aa409cb3ddb93e1f9f4f6374376109241a95ef8c36af842de1f6f76e8
diff --git a/x11-apps/xauth/xauth-1.1.2.ebuild b/x11-apps/xauth/xauth-1.1.2.ebuild
new file mode 100644
index 000000000000..9ba0a5a1b7f6
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index 50da5eb529dd..9ba0a5a1b7f6 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
+XORG_TARBALL_SUFFIX=xz
inherit xorg-3
if [[ ${PV} == 9999* ]]; then
SRC_URI=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6"
-RESTRICT="test" # Depends on dead cmdtest package
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXau
x11-libs/libXext
x11-libs/libXmu"
@@ -24,7 +23,7 @@ DEPEND="${RDEPEND}
src_configure() {
local XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
+ --enable-ipv6
)
xorg-3_src_configure
}