summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-03 14:34:37 -0800
committerMatt Turner <mattst88@gentoo.org>2019-05-15 11:51:14 -0700
commit491cd4d5509dd2f6866a5aaa6184c68915eb9652 (patch)
tree43e4a11390fbe730b81d0c244721d01cdd2ae75e /x11-apps/xinit
parentmedia-libs/opusfile: Drop 0.6 and 0.10 (diff)
downloadgentoo-491cd4d5509dd2f6866a5aaa6184c68915eb9652.tar.gz
gentoo-491cd4d5509dd2f6866a5aaa6184c68915eb9652.tar.bz2
gentoo-491cd4d5509dd2f6866a5aaa6184c68915eb9652.zip
x11-apps/xinit: Version bump to 1.4.1
Use a patch from Debian to resolve bug 379441. Closes: https://bugs.gentoo.org/379441 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/Manifest1
-rw-r--r--x11-apps/xinit/files/xinit-1.4.1-move-serverauthfile-into-tmp.patch22
-rw-r--r--x11-apps/xinit/xinit-1.4.1.ebuild76
3 files changed, 99 insertions, 0 deletions
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index 396082655b11..8b2e86bb882f 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -1 +1,2 @@
DIST xinit-1.4.0.tar.bz2 174491 BLAKE2B 5a613a244a22f3bb4de43ae23b8f590b41a6af2c3adb282d2a089f4b94117220d86654c16cbb20ad0a50b6aab1be65512a7a42850e9047cfca96f25af964d081 SHA512 53a29081130c1e195eb441ee77ccaa044b18b4cca3d2d5da3a6d67aa421dfd9718fa18b6be6232a41e40cf260c8190064c4d8d9ab771177bd5cd12e77a8fa79e
+DIST xinit-1.4.1.tar.bz2 176206 BLAKE2B 1c20f34db344eb967ac230a0cd61ad07d0089668aea32973e9b8b9749e5260ad5d93a7f6642a4f2c8d6b01870696e4e1e422790c2954320039aa85e6dba8870a SHA512 6cbc5d025a891c419f3f4493381b2fca57a67d78df866d2f16a83426f86bad6eca7f240fac12b25cbcc63df0fec41f625407184e044898602d66483715315340
diff --git a/x11-apps/xinit/files/xinit-1.4.1-move-serverauthfile-into-tmp.patch b/x11-apps/xinit/files/xinit-1.4.1-move-serverauthfile-into-tmp.patch
new file mode 100644
index 000000000000..339b65311712
--- /dev/null
+++ b/x11-apps/xinit/files/xinit-1.4.1-move-serverauthfile-into-tmp.patch
@@ -0,0 +1,22 @@
+Move startx auth files in /tmp so they are removed on reboot.
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=357736
+The trap patch didn't seem to work on reboot.
+---
+ startx.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/startx.cpp
++++ b/startx.cpp
+@@ -278,11 +278,11 @@ if [ x"$enable_xauth" = x1 ] ; then
+ exit 1
+ fi
+ dummy=0
+
+ XCOMM create a file with auth information for the server. ':0' is a dummy.
+- xserverauthfile=$HOME/.serverauth.$$
++ xserverauthfile=`mktemp --tmpdir serverauth.XXXXXXXXXX`
+ trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP KILL BUS TERM
+ xauth -q -f "$xserverauthfile" << EOF
+ add :$dummy . $mcookie
+ EOF
+ #if defined(__APPLE__) || defined(__CYGWIN__)
diff --git a/x11-apps/xinit/xinit-1.4.1.ebuild b/x11-apps/xinit/xinit-1.4.1.ebuild
new file mode 100644
index 000000000000..4c26bd5588c0
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.4.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.4.0-startx-current-vt.patch"
+ "${FILESDIR}/${PN}-1.4.1-move-serverauthfile-into-tmp.patch"
+)
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+)
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.2 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-3_pkg_postinst
+
+ if ! has_version 'x11-apps/xinit'; then
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+ fi
+
+ if has_version "<${CATEGORY}/${PN}-1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+}