summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-09 18:18:47 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-09 18:29:25 -0800
commit23a81ba44cf153563a566987ce1513258e5c02fd (patch)
tree55e5622ab5197687875ef3dd33ca012748da5db1 /x11-apps
parentx11-apps/xbacklight: Version bump to 1.2.2 (diff)
downloadgentoo-23a81ba44cf153563a566987ce1513258e5c02fd.tar.gz
gentoo-23a81ba44cf153563a566987ce1513258e5c02fd.tar.bz2
gentoo-23a81ba44cf153563a566987ce1513258e5c02fd.zip
x11-apps/xinit: Version bump to 1.4.0
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/Manifest1
-rw-r--r--x11-apps/xinit/xinit-1.4.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index e9bba13bce07..c8a83bfc0c52 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -1 +1,2 @@
DIST xinit-1.3.4.tar.bz2 165881 BLAKE2B 78e0b9e8fdb146e969014d726ac05e7f4cf14947aa6026642fbbe6a55eb9c5cb891f079281bb40b460f9b1373259e338dcc0615fbdda64da49b719980017b782 SHA512 ac31e4cac86fc5dd4c0e15cf37cb9ac470ef3ace4f86d0063c7e1091342fe64d41fcd12c1840bd8e1cef4cdd7f66bd2fa76bd4061641e9c70941d76d73d0df2e
+DIST xinit-1.4.0.tar.bz2 174491 BLAKE2B 5a613a244a22f3bb4de43ae23b8f590b41a6af2c3adb282d2a089f4b94117220d86654c16cbb20ad0a50b6aab1be65512a7a42850e9047cfca96f25af964d081 SHA512 53a29081130c1e195eb441ee77ccaa044b18b4cca3d2d5da3a6d67aa421dfd9718fa18b6be6232a41e40cf260c8190064c4d8d9ab771177bd5cd12e77a8fa79e
diff --git a/x11-apps/xinit/xinit-1.4.0.ebuild b/x11-apps/xinit/xinit-1.4.0.ebuild
new file mode 100644
index 000000000000..ea3e115f959f
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.4.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.3.4-startx-current-vt.patch"
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.1 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}