summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-03 10:01:27 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-03 10:06:54 -0700
commit30c76834821912a8b4497685cd120d35040c75d7 (patch)
tree52d86ce4cef1ee2d2e61c7f95e7411f6b716f196 /x11-apps
parentnet-wireless/kismetmobiledashboard: remove python references (diff)
downloadgentoo-30c76834821912a8b4497685cd120d35040c75d7.tar.gz
gentoo-30c76834821912a8b4497685cd120d35040c75d7.tar.bz2
gentoo-30c76834821912a8b4497685cd120d35040c75d7.zip
x11-apps/xauth: Drop testing support
I never found the testing to be valuable, and it depends on the Python 2.7-only (and dead) cmdtest package which is being removed. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild10
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild10
2 files changed, 4 insertions, 16 deletions
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
index 838c880146d3..bde249ad877b 100644
--- a/x11-apps/xauth/xauth-1.1.ebuild
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -12,8 +12,8 @@ else
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6 test"
-RESTRICT="!test? ( test )"
+IUSE="ipv6"
+RESTRICT="test" # Depends on dead cmdtest package
RDEPEND="x11-libs/libX11
x11-libs/libXau
@@ -21,15 +21,9 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-BDEPEND="test? ( dev-util/cmdtest )"
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
}
-
-src_test() {
- addwrite /proc/self/comm
- emake check
-}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index 303aa1063e26..f46da39bc300 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -12,8 +12,8 @@ else
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6 test"
-RESTRICT="!test? ( test )"
+IUSE="ipv6"
+RESTRICT="test" # Depends on dead cmdtest package
RDEPEND="x11-libs/libX11
x11-libs/libXau
@@ -21,15 +21,9 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-BDEPEND="test? ( dev-util/cmdtest )"
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
}
-
-src_test() {
- addwrite /proc/self/comm
- emake check
-}