summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-30 13:20:43 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-30 13:24:59 -0400
commit6b4d370c80d54fb56b6fb933c6f346f3651e7c66 (patch)
tree0e2f96bb5144664715d2ac9552ed159db20b42cf /x11-apps
parentx11-apps/mesa-progs: Switch to meson (diff)
downloadgentoo-6b4d370c80d54fb56b6fb933c6f346f3651e7c66.tar.gz
gentoo-6b4d370c80d54fb56b6fb933c6f346f3651e7c66.tar.bz2
gentoo-6b4d370c80d54fb56b6fb933c6f346f3651e7c66.zip
x11-apps/mesa-progs: Version bump to 8.5.0
Closes: https://bugs.gentoo.org/841779 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/mesa-progs/Manifest1
-rw-r--r--x11-apps/mesa-progs/mesa-progs-8.5.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-apps/mesa-progs/Manifest b/x11-apps/mesa-progs/Manifest
index 3f7b33bcee0b..4b8c4f40c9af 100644
--- a/x11-apps/mesa-progs/Manifest
+++ b/x11-apps/mesa-progs/Manifest
@@ -1 +1,2 @@
DIST mesa-demos-8.4.0.tar.bz2 10073259 BLAKE2B d251e705c6e3d2fe959161d736401fd06ba267a9c389341098373670b6f44ca7cdb451d96e94e3b22f006b696a9b19e38096423f6438544539f46beda91c03f4 SHA512 b72d03cad36e0535ff18dcfb222ec4200064b9264f6da51a6e5f03b0dd912abe188bc1d600b6698de3ce6f63b28d2ce01565886ca8e7079edc4967fbf2fb0957
+DIST mesa-demos-8.5.0.tar.bz2 10367517 BLAKE2B 60e9edfcfe6d28f73964b81ae4e016fdbeb45d9d6d91de71bf736c86fa6181749f2e12729c8c716f6e6f5d4e39075de131877d1f09c3e511a4338b0f44ddb6a6 SHA512 df6a7f09638ca389d6e8bc569e599dcc59c9aa280bcfb95976d83e5cd3edfe74bb3a31f0953956dc16faa540ee5b09990e3377e1341d836fc527e50ace6e60b8
diff --git a/x11-apps/mesa-progs/mesa-progs-8.5.0.ebuild b/x11-apps/mesa-progs/mesa-progs-8.5.0.ebuild
new file mode 100644
index 000000000000..0de99d7b802b
--- /dev/null
+++ b/x11-apps/mesa-progs/mesa-progs-8.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+MY_PN="${PN/progs/demos}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Mesa's OpenGL utility and demo programs (glxgears and glxinfo)"
+HOMEPAGE="https://www.mesa3d.org/ https://mesa.freedesktop.org/ https://gitlab.freedesktop.org/mesa/demos"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/demos.git"
+else
+ SRC_URI="https://mesa.freedesktop.org/archive/demos/${MY_P}.tar.bz2
+ https://mesa.freedesktop.org/archive/demos/${PV}/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="gles2 wayland X"
+
+RDEPEND="
+ media-libs/mesa[${MULTILIB_USEDEP},egl(+),gles2?,wayland?,X?]
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+PATCHES=(
+ "${FILESDIR}"/8.5.0-Disable-things-we-don-t-want.patch
+)
+
+pkg_setup() {
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/eglinfo
+ )
+
+ use X && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/glxgears
+ /usr/bin/glxinfo
+ )
+
+ use gles2 && use X && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/es2_info
+ /usr/bin/es2gears_x11
+ )
+
+ use gles2 && use wayland && MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/es2gears_wayland
+ )
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dlibdrm=disabled
+ -Degl=enabled
+ -Dgles1=disabled
+ $(meson_feature gles2)
+ -Dosmesa=disabled
+ $(meson_feature wayland)
+ $(meson_feature X x11)
+ )
+ meson_src_configure
+}