summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-03-11 10:07:22 +0100
committerMatt Turner <mattst88@gentoo.org>2021-03-12 23:14:12 -0500
commit7ead5c74267c8068754d086603b1c0ffb88c5749 (patch)
tree08eb236007009a3f793c0442e0ca5d7b1eb4cfbf /x11-apps
parentx11-apps/xlsclients: EAPI 7 (diff)
downloadgentoo-7ead5c74267c8068754d086603b1c0ffb88c5749.tar.gz
gentoo-7ead5c74267c8068754d086603b1c0ffb88c5749.tar.bz2
gentoo-7ead5c74267c8068754d086603b1c0ffb88c5749.zip
x11-apps/xdriinfo: EAPI 7
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..12d615ee4f87
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3 flag-o-matic
+
+DESCRIPTION="query configuration information of DRI drivers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ xorg-3_pkg_setup
+
+ append-cppflags "-I${EPREFIX}/usr/$(get_libdir)/opengl/xorg-x11/include/"
+}