summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 18:31:02 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 18:49:08 -0500
commitc8ac6fe036ab10a805799c42464b3f0af6d60e2c (patch)
tree94460d693ff7ac026f914cc445866c2f81d7c9f1 /x11-apps
parentx11-apps/xgamma: Version bump to 1.0.7 (diff)
downloadgentoo-c8ac6fe036ab10a805799c42464b3f0af6d60e2c.tar.gz
gentoo-c8ac6fe036ab10a805799c42464b3f0af6d60e2c.tar.bz2
gentoo-c8ac6fe036ab10a805799c42464b3f0af6d60e2c.zip
x11-apps/xinit: Version bump to 1.4.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/Manifest1
-rw-r--r--x11-apps/xinit/files/xinit-1.4.2-move-serverauthfile-into-tmp.patch23
-rw-r--r--x11-apps/xinit/files/xinit-1.4.2-startx-current-vt.patch25
-rw-r--r--x11-apps/xinit/xinit-1.4.2.ebuild76
4 files changed, 125 insertions, 0 deletions
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index ede67dd74923..a743e32e2550 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -1 +1,2 @@
DIST xinit-1.4.1.tar.bz2 176206 BLAKE2B 1c20f34db344eb967ac230a0cd61ad07d0089668aea32973e9b8b9749e5260ad5d93a7f6642a4f2c8d6b01870696e4e1e422790c2954320039aa85e6dba8870a SHA512 6cbc5d025a891c419f3f4493381b2fca57a67d78df866d2f16a83426f86bad6eca7f240fac12b25cbcc63df0fec41f625407184e044898602d66483715315340
+DIST xinit-1.4.2.tar.xz 156728 BLAKE2B 8f5c16d5ec9cc16c734b1661def4f7e68321259f24e7aac2b039b8e142fb4a324d2471a0f04d3b4448ae713082ad9ec7018083b00ed1a93aac90fa7db172247d SHA512 4b62c2edd97b40133577cbba88b3f31b36c5634b4eb667ef0c302e8358dc1c55a255abe42aaadc910d8aa9ea0e3add157a12a301382f1cdbe091df4e1215fae0
diff --git a/x11-apps/xinit/files/xinit-1.4.2-move-serverauthfile-into-tmp.patch b/x11-apps/xinit/files/xinit-1.4.2-move-serverauthfile-into-tmp.patch
new file mode 100644
index 000000000000..22b733fbdbba
--- /dev/null
+++ b/x11-apps/xinit/files/xinit-1.4.2-move-serverauthfile-into-tmp.patch
@@ -0,0 +1,23 @@
+Move startx auth files in /tmp so they are removed on reboot.
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=357736
+The trap patch didn't seem to work on reboot.
+---
+ startx.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/startx.cpp b/startx.cpp
+index 082f780..9f9ff00 100644
+--- a/startx.cpp
++++ b/startx.cpp
+@@ -261,7 +261,7 @@ if [ x"$enable_xauth" = x1 ] ; then
+ dummy=0
+
+ XCOMM create a file with auth information for the server. ':0' is a dummy.
+- xserverauthfile=$HOME/.serverauth.$$
++ xserverauthfile=`mktemp --tmpdir serverauth.XXXXXXXXXX`
+ trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP BUS TERM
+ xauth -q -f "$xserverauthfile" << EOF
+ add :$dummy . $mcookie
+--
+2.37.4
+
diff --git a/x11-apps/xinit/files/xinit-1.4.2-startx-current-vt.patch b/x11-apps/xinit/files/xinit-1.4.2-startx-current-vt.patch
new file mode 100644
index 000000000000..979d5260a13f
--- /dev/null
+++ b/x11-apps/xinit/files/xinit-1.4.2-startx-current-vt.patch
@@ -0,0 +1,25 @@
+diff --git a/startx.cpp b/startx.cpp
+index dfbebe1..082f780 100644
+--- a/startx.cpp
++++ b/startx.cpp
+@@ -202,17 +202,6 @@ XCOMM process server arguments
+ if [ x"$server" = x ]; then
+ server=$defaultserver
+
+-#ifdef __linux__
+- XCOMM When starting the defaultserver start X on the current tty to avoid
+- XCOMM the startx session being seen as inactive:
+- XCOMM "https://bugzilla.redhat.com/show_bug.cgi?id=806491"
+- tty=$(tty)
+- if expr "$tty" : '/dev/tty[0-9][0-9]*$' > /dev/null; then
+- tty_num=${tty#/dev/tty}
+- vtarg="vt$tty_num -keeptty"
+- fi
+-#endif
+-
+ XCOMM For compatibility reasons, only use xserverrc if there were no server command line arguments
+ if [ x"$serverargs" = x -a x"$display" = x ]; then
+ if [ -f "$userserverrc" ]; then
+--
+2.37.4
+
diff --git a/x11-apps/xinit/xinit-1.4.2.ebuild b/x11-apps/xinit/xinit-1.4.2.ebuild
new file mode 100644
index 000000000000..73e5d99f7ffb
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.4.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="twm"
+
+RDEPEND="
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ twm? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.4.2-startx-current-vt.patch"
+ "${FILESDIR}/${PN}-1.4.2-move-serverauthfile-into-tmp.patch"
+)
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+)
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.2 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+ fi
+
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+ done
+}