summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-11 22:58:25 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-11 22:59:23 -0700
commitd7aa57ee237e9ff8ef7d4906af5a3b7e6faafd12 (patch)
treeb7f77b49f1b69e86c9f664abc456946c9266db62 /x11-apps
parentx11-apps/xauth: Port to EAPI=7 (diff)
downloadgentoo-d7aa57ee237e9ff8ef7d4906af5a3b7e6faafd12.tar.gz
gentoo-d7aa57ee237e9ff8ef7d4906af5a3b7e6faafd12.tar.bz2
gentoo-d7aa57ee237e9ff8ef7d4906af5a3b7e6faafd12.zip
x11-apps/xauth: Version bump to 1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/Manifest1
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index e47d92ad1f99..2f9672cc9148 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1 +1,2 @@
DIST xauth-1.0.10.tar.bz2 162176 BLAKE2B 0a3a70360357f0f1a36a72e54b404526e62ddabbdc8b2e6ed992ceb56847fa983b9cec1ba23aab92f4b2fe0712f097a8721d7c50a4b4ead217a5704cda76ea82 SHA512 1ddcd80848c4efffc6d0a576177f92a3ce47eb871a6c7e2097d96491aec027404d437e0bd792714ef423989153a9644f5ff179bde4dfeb4b340636d642d5849f
+DIST xauth-1.1.tar.bz2 163510 BLAKE2B 0b55ee9ec35ca436c36effe2ba4eee55f76a311a5482d1d72e80e5afea30c682de3f686b2956d17278721e190dd9bec4d93db6507853841a633c931312df745d SHA512 b6ecd59a853a491ef45bf8cfbff63bed36645f81cb79ae9d18458b57f7502bccf92f0d979d3337578518646f680ad379e67b1dac15a927cbb11372733e7a3a0c
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
new file mode 100644
index 000000000000..057d3ed2a71e
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+IUSE="ipv6 test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="test? ( dev-util/cmdtest )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+}
+
+src_test() {
+ addwrite /proc/self/comm
+ emake check
+}