summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-07-03 22:06:11 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-07-03 22:07:13 +0200
commit44466a67e2532ce119ee308b98c426b580857c89 (patch)
tree9f06a47de0614a1da05a187c7256967f2c82598a /x11-base/xorg-server
parentx11-base/xwayland: align ebuilds. (diff)
downloadgentoo-44466a67e2532ce119ee308b98c426b580857c89.tar.gz
gentoo-44466a67e2532ce119ee308b98c426b580857c89.tar.bz2
gentoo-44466a67e2532ce119ee308b98c426b580857c89.zip
x11-base/xorg-server: align 9999 ebuild with xwayland split.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-base/xorg-server')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index 1b2a33ee9084..70fb5f6bd29f 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -68,11 +68,6 @@ CDEPEND="
)
udev? ( virtual/libudev:= )
unwind? ( sys-libs/libunwind )
- wayland? (
- >=dev-libs/wayland-1.3.0
- >=media-libs/libepoxy-1.5.4[egl(+)]
- >=dev-libs/wayland-protocols-1.18
- )
>=x11-apps/xinit-1.3.3-r1
systemd? (
sys-apps/dbus
@@ -97,6 +92,7 @@ DEPEND="${CDEPEND}
)
)
)
+ wayland? ( x11-base/xwayland )
"
RDEPEND="${CDEPEND}
!systemd? ( gui-libs/display-manager-init )
@@ -104,7 +100,6 @@ RDEPEND="${CDEPEND}
"
BDEPEND="
sys-devel/flex
- wayland? ( dev-util/wayland-scanner )
"
PDEPEND="
xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
@@ -127,14 +122,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
)
-pkg_setup() {
- if use wayland && use minimal; then
- ewarn "glamor is necessary for acceleration under Xwayland."
- ewarn "Performance may be unacceptable without it."
- ewarn "Build with USE=-minimal to enable glamor."
- fi
-}
-
src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
@@ -148,7 +135,6 @@ src_configure() {
$(use_enable kdrive)
$(use_enable test unit-tests)
$(use_enable unwind libunwind)
- $(use_enable wayland xwayland)
$(use_enable !minimal record)
$(use_enable !minimal xfree86-utils)
$(use_enable !minimal dri)
@@ -165,6 +151,7 @@ src_configure() {
$(use_with doc doxygen)
$(use_with doc xmlto)
$(use_with systemd systemd-daemon)
+ --disable-xwayland
--enable-libdrm
--sysconfdir="${EPREFIX}"/etc/X11
--localstatedir="${EPREFIX}"/var
@@ -174,6 +161,7 @@ src_configure() {
--disable-linux-acpi
--without-dtrace
--without-fop
+ --with-os-vendor=Gentoo
--with-sha1=libcrypto
CPP="$(tc-getPROG CPP cpp)"
)