summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-21 00:51:30 +0000
committerSam James <sam@gentoo.org>2021-12-21 00:51:30 +0000
commitc40287e2a259a9d9e13ee6055748d4d5b0b9f8b9 (patch)
treea99c3c34a7baadc8121dc8ae894bc140af20e956 /x11-base
parentmedia-sound/teamspeak-client: drop 5.0.0_beta65 (diff)
downloadgentoo-c40287e2a259a9d9e13ee6055748d4d5b0b9f8b9.tar.gz
gentoo-c40287e2a259a9d9e13ee6055748d4d5b0b9f8b9.tar.bz2
gentoo-c40287e2a259a9d9e13ee6055748d4d5b0b9f8b9.zip
x11-base/xorg-server: backport upstream resume/logind fix
Closes: https://bugs.gentoo.org/829496 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.2-fix-resume-logind.patch148
-rw-r--r--x11-base/xorg-server/xorg-server-21.1.2-r3.ebuild185
2 files changed, 333 insertions, 0 deletions
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.2-fix-resume-logind.patch b/x11-base/xorg-server/files/xorg-server-21.1.2-fix-resume-logind.patch
new file mode 100644
index 000000000000..1d16e132f62a
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-server-21.1.2-fix-resume-logind.patch
@@ -0,0 +1,148 @@
+Merged upstream into master, this is the backport PR variant.
+
+https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/833
+https://bugs.gentoo.org/829496
+
+From: Jocelyn Falempe <jfalempe@redhat.com>
+Date: Thu, 16 Dec 2021 15:46:43 +0100
+Subject: [PATCH 1/2] xf86/logind: Fix compilation error when built without
+ logind/platform bus
+
+This was introduced by commit 8eb1396d
+
+Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1269
+Fixes: da9d012a9 - xf86/logind: Fix drm_drop_master before vt_reldisp
+
+Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
+Reviewed-by: Hans de Goede <hdegoede@redhat.com>
+--- a/hw/xfree86/common/xf86Events.c
++++ b/hw/xfree86/common/xf86Events.c
+@@ -383,14 +383,7 @@ xf86VTLeave(void)
+ xf86GPUScreens[i]->LeaveVT(xf86GPUScreens[i]);
+
+ if (systemd_logind_controls_session()) {
+- for (i = 0; i < xf86_num_platform_devices; i++) {
+- if (xf86_platform_devices[i].flags & XF86_PDEV_SERVER_FD) {
+- int major, minor;
+- major = xf86_platform_odev_attributes(i)->major;
+- minor = xf86_platform_odev_attributes(i)->minor;
+- systemd_logind_drop_master(major, minor);
+- }
+- }
++ systemd_logind_drop_master();
+ }
+
+ if (!xf86VTSwitchAway())
+--- a/hw/xfree86/os-support/linux/systemd-logind.c
++++ b/hw/xfree86/os-support/linux/systemd-logind.c
+@@ -308,13 +308,19 @@ cleanup:
+ * and ensure the drm_drop_master is done before
+ * VT_RELDISP when switching VT
+ */
+-void systemd_logind_drop_master(int _major, int _minor)
++void systemd_logind_drop_master(void)
+ {
+- struct systemd_logind_info *info = &logind_info;
+- dbus_int32_t major = _major;
+- dbus_int32_t minor = _minor;
++ int i;
++ for (i = 0; i < xf86_num_platform_devices; i++) {
++ if (xf86_platform_devices[i].flags & XF86_PDEV_SERVER_FD) {
++ dbus_int32_t major, minor;
++ struct systemd_logind_info *info = &logind_info;
+
+- systemd_logind_ack_pause(info, minor, major);
++ major = xf86_platform_odev_attributes(i)->major;
++ minor = xf86_platform_odev_attributes(i)->minor;
++ systemd_logind_ack_pause(info, minor, major);
++ }
++ }
+ }
+
+ static DBusHandlerResult
+--- a/include/systemd-logind.h
++++ b/include/systemd-logind.h
+@@ -33,7 +33,7 @@ int systemd_logind_take_fd(int major, int minor, const char *path, Bool *paus);
+ void systemd_logind_release_fd(int major, int minor, int fd);
+ int systemd_logind_controls_session(void);
+ void systemd_logind_vtenter(void);
+-void systemd_logind_drop_master(int major, int minor);
++void systemd_logind_drop_master(void);
+ #else
+ #define systemd_logind_init()
+ #define systemd_logind_fini()
+@@ -41,7 +41,7 @@ void systemd_logind_drop_master(int major, int minor);
+ #define systemd_logind_release_fd(major, minor, fd) close(fd)
+ #define systemd_logind_controls_session() 0
+ #define systemd_logind_vtenter()
+-#define systemd_logind_drop_master(major, minor)
++#define systemd_logind_drop_master()
+ #endif
+
+ #endif
+GitLab
+From 66890ca569291a53ea9cdc6ec19070173e522260 Mon Sep 17 00:00:00 2001
+From: Jocelyn Falempe <jfalempe@redhat.com>
+Date: Fri, 17 Dec 2021 10:18:25 +0100
+Subject: [PATCH 2/2] xf86/logind: fix missing call to vtenter if the platform
+ device is not paused
+
+If there is one platform device, which is not paused nor resumed,
+systemd_logind_vtenter() will never get called.
+This break suspend/resume, and switching to VT on system with Nvidia
+proprietary driver.
+This is a regression introduced by f5bd039633fa83
+
+So now call systemd_logind_vtenter() if there are no paused
+platform devices.
+
+Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1271
+Fixes: f5bd0396 - xf86/logind: fix call systemd_logind_vtenter after receiving drm device resume
+
+Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
+Tested-by: Olivier Fourdan <ofourdan@redhat.com>
+Reviewed-by: Hans de Goede <hdegoede@redhat.com>
+--- a/hw/xfree86/os-support/linux/systemd-logind.c
++++ b/hw/xfree86/os-support/linux/systemd-logind.c
+@@ -316,6 +316,7 @@ void systemd_logind_drop_master(void)
+ dbus_int32_t major, minor;
+ struct systemd_logind_info *info = &logind_info;
+
++ xf86_platform_devices[i].flags |= XF86_PDEV_PAUSED;
+ major = xf86_platform_odev_attributes(i)->major;
+ minor = xf86_platform_odev_attributes(i)->minor;
+ systemd_logind_ack_pause(info, minor, major);
+@@ -323,6 +324,16 @@ void systemd_logind_drop_master(void)
+ }
+ }
+
++static Bool are_platform_devices_resumed(void) {
++ int i;
++ for (i = 0; i < xf86_num_platform_devices; i++) {
++ if (xf86_platform_devices[i].flags & XF86_PDEV_PAUSED) {
++ return FALSE;
++ }
++ }
++ return TRUE;
++}
++
+ static DBusHandlerResult
+ message_filter(DBusConnection * connection, DBusMessage * message, void *data)
+ {
+@@ -416,13 +427,11 @@ message_filter(DBusConnection * connection, DBusMessage * message, void *data)
+
+ if (pdev) {
+ pdev->flags &= ~XF86_PDEV_PAUSED;
+- systemd_logind_vtenter();
+ } else
+ systemd_logind_set_input_fd_for_all_devs(major, minor, fd,
+ info->vt_active);
+-
+- /* Always call vtenter(), only if there are only legacy video devs */
+- if (!xf86_num_platform_devices)
++ /* Call vtenter if all platform devices are resumed, or if there are no platform device */
++ if (are_platform_devices_resumed())
+ systemd_logind_vtenter();
+ }
+ return DBUS_HANDLER_RESULT_HANDLED;
+GitLab
diff --git a/x11-base/xorg-server/xorg-server-21.1.2-r3.ebuild b/x11-base/xorg-server/xorg-server-21.1.2-r3.ebuild
new file mode 100644
index 000000000000..3f1a181bcf83
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-21.1.2-r3.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_EAUTORECONF="no"
+inherit xorg-3 meson
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+
+DESCRIPTION="X.Org X servers"
+SLOT="0/${PV}"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+IUSE_SERVERS="xephyr xnest xorg xvfb"
+IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ media-libs/libglvnd[X]
+ dev-libs/libbsd
+ dev-libs/openssl:0=
+ >=x11-apps/iceauth-1.0.2
+ >=x11-apps/rgb-1.0.3
+ >=x11-apps/xauth-1.0.3
+ x11-apps/xkbcomp
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libpciaccess-0.12.901
+ >=x11-libs/libXau-1.0.4
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ >=x11-libs/libxcvt-0.1.0
+ >=x11-libs/libxkbfile-1.0.4
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xbitmaps-1.0.1
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+ >=x11-libs/libXext-1.0.5
+ x11-libs/libXv
+ xephyr? (
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+ !minimal? (
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libXext-1.0.5
+ >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ )
+ udev? ( virtual/libudev:= )
+ unwind? ( sys-libs/libunwind )
+ selinux? ( sys-libs/libselinux )
+ systemd? (
+ sys-apps/dbus
+ sys-apps/systemd
+ )
+ elogind? (
+ sys-apps/dbus
+ sys-auth/elogind[pam]
+ sys-auth/pambase[elogind]
+ )
+ !!x11-drivers/nvidia-drivers[-libglvnd(+)]
+"
+DEPEND="${CDEPEND}
+ >=x11-base/xorg-proto-2021.4.99.2
+ >=x11-libs/xtrans-1.3.5
+ media-fonts/font-util
+"
+RDEPEND="${CDEPEND}
+ !systemd? ( gui-libs/display-manager-init )
+ selinux? ( sec-policy/selinux-xserver )
+ xorg? ( >=x11-apps/xinit-1.3.3-r1 )
+"
+BDEPEND="
+ sys-devel/flex
+"
+PDEPEND="
+ xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
+
+REQUIRED_USE="!minimal? (
+ || ( ${IUSE_SERVERS} )
+ )
+ elogind? ( udev )
+ ?? ( elogind systemd )"
+
+UPSTREAMED_PATCHES=(
+ "${FILESDIR}"/${P}-fix-resume-logind.patch
+)
+
+PATCHES=(
+ "${UPSTREAMED_PATCHES[@]}"
+ "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
+ # needed for new eselect-opengl, bug #541232
+ "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
+)
+
+src_configure() {
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+
+ local emesonargs=(
+ --localstatedir "${EPREFIX}/var"
+ --sysconfdir "${EPREFIX}/etc/X11"
+ --buildtype $(usex debug debug plain)
+ -Db_ndebug=$(usex debug false true)
+ $(meson_use !minimal dri1)
+ $(meson_use !minimal dri2)
+ $(meson_use !minimal dri3)
+ $(meson_use !minimal glamor)
+ $(meson_use !minimal glx)
+ $(meson_use udev)
+ $(meson_use udev udev_kms)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use xephyr)
+ $(meson_use xnest)
+ $(meson_use xorg)
+ $(meson_use xvfb)
+ -Ddocs=false
+ -Ddrm=true
+ -Ddtrace=false
+ -Dipv6=true
+ -Dhal=false
+ -Dlinux_acpi=false
+ -Dlinux_apm=false
+ -Dsecure-rpc=false
+ -Dsha1=libcrypto
+ -Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
+ )
+
+ if [[ ${PV} == 9999 ]] ; then
+ # Gone in 21.1.x, but not in master.
+ emesonargs+=( -Dxwayland=false )
+ fi
+
+ if use systemd || use elogind; then
+ emesonargs+=(
+ -Dsystemd_logind=true
+ $(meson_use suid suid_wrapper)
+ )
+ else
+ emesonargs+=(
+ -Dsystemd_logind=false
+ -Dsuid_wrapper=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # The meson build system does not support install-setuid
+ if ! use systemd || ! use elogind; then
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/Xorg
+ fi
+ fi
+
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
+
+ # install the @x11-module-rebuild set for Portage
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}"/xorg-sets.conf xorg.conf
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
+ rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
+ fi
+}