summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-15 21:45:53 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-15 21:49:10 -0500
commitcf8a9fa537bce705741480e842b6e5cbf1f5b079 (patch)
tree033c1c748011ba612ca4fabf94e16a32141d79c5 /x11-base
parentx11-base/xorg-server: Version bump to 21.1.2 (diff)
downloadgentoo-cf8a9fa537bce705741480e842b6e5cbf1f5b079.tar.gz
gentoo-cf8a9fa537bce705741480e842b6e5cbf1f5b079.tar.bz2
gentoo-cf8a9fa537bce705741480e842b6e5cbf1f5b079.zip
x11-base/xwayland: Version bump to 21.1.4
Also remove IUSE=rpc (see commit 72c14cae8f9e for rationale). Bug: https://bugs.gentoo.org/829208 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-21.1.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 89b04f4ede09..655fd9c12208 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-21.1.2.tar.xz 1258732 BLAKE2B 1a797e4dedee4f47ada968d4a06c89da2fac64bbfa587e84f01d5b0aa7da23402b70369a274a672470e6d8df0645fd117d129d1f2049b25394d825a9eed3e451 SHA512 3bd595a563cbc44b49a00c85adabdbcddf02fd55c6500ed2711557c156f10cd273af93f7b232865141ad27392a85583e40268bcedad183ad9eeefba457cef6c6
DIST xwayland-21.1.3.tar.xz 1261776 BLAKE2B bccecc3386ceb7e612929139b5b73e038df684bc43d9554c1196c4c3e66f200b346ea8615ec9224ae999400f34881d5f29365f06d4487bf4dda381c03b83e05b SHA512 24147ef788cce3fa16cd5604d293ffbe7ef4c6dc5fc2b1a1018d78ca4c0f10ade7b99c1ad6a8cdca5c581ff40f5834d7e34b2a314acca665a527eed700993594
+DIST xwayland-21.1.4.tar.xz 1261712 BLAKE2B 698886d450f340c4a275f583d27382a5ee22c09255d907bbe2babc6794da1827bd5bf3e575b9da77ff3b3c5c4cd3e30cc10b89d14e0f6365d2a71f8ade61e410 SHA512 54e18565b4c2514534501ddcc76058d6911cf0c2185cddf5c54833d317f51ba8eb8934bd9be269518ece05f3bc8cda81600b25871c61437c923eba916eccc525
diff --git a/x11-base/xwayland/xwayland-21.1.4.ebuild b/x11-base/xwayland/xwayland-21.1.4.ebuild
new file mode 100644
index 000000000000..8cc2e527c783
--- /dev/null
+++ b/x11-base/xwayland/xwayland-21.1.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=x11-libs/pixman-0.27.2
+ dev-libs/libbsd
+ >=x11-libs/libXfont2-2.0.1
+ dev-libs/openssl:=
+ dev-libs/wayland
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libdrm-2.4.89
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/libXau-1.0.4
+ media-libs/libglvnd[X]
+ unwind? ( sys-libs/libunwind )
+ >=dev-libs/wayland-protocols-1.18
+ media-fonts/font-util
+ x11-libs/libxkbfile
+ >=x11-libs/xtrans-1.3.5
+ x11-base/xorg-proto
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Drpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}