summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-16 19:31:37 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-17 07:15:21 -0700
commitbfaa9f12ebe84877d137b4f37d37512044e00d96 (patch)
tree3e22caaf8cd5cf1403d3d9daacd60c9aa711b1f2 /x11-drivers/xf86-input-libinput
parentx11-drivers/xf86-input-evdev: add live ebuild (diff)
downloadgentoo-bfaa9f12ebe84877d137b4f37d37512044e00d96.tar.gz
gentoo-bfaa9f12ebe84877d137b4f37d37512044e00d96.tar.bz2
gentoo-bfaa9f12ebe84877d137b4f37d37512044e00d96.zip
x11-drivers/xf86-input-libinput: version bump to 0.28.0
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'x11-drivers/xf86-input-libinput')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest1
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index 80d35bdaec39..1e136185f348 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1 +1,2 @@
DIST xf86-input-libinput-0.27.1.tar.bz2 373248 BLAKE2B 499c5c1b33f5159374775317777741db361620583f9d647ab5ee63193f5b82ecbbe5c124a447509c6b7de281cf6330f9747032d8bad8c2b1dbbcdd4517cf4f82 SHA512 01379f5d71bf39214c4dff428173512df57fd12e782f3fcde757be923aa0dbf4e010a0395a81bd8e4fb518edc7e05ca1ee64b1e313eb4df5d4990315580609a1
+DIST xf86-input-libinput-0.28.0.tar.bz2 374318 BLAKE2B b8629115fce658d9d432c05a983227aa1fa40da51e14c366bc0880b9d7c81c971abcb4c4b60ec37b756efad60be8eef061c0d3dcdd86f4fdb8b56e13f4ed9409 SHA512 4276b6aea87ddc83fa1f5e8d8949e34ad117186a6b5b599549231cb90424cd0fa69f3a4701ce529739c676665bb5c936eb447817c9420511d23bc048f6be92a4
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
new file mode 100644
index 000000000000..b3ca6c70ccb5
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="X.org input driver based on libinput"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-input-libinput.git"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-base/xorg-server-1.10:=
+ >=dev-libs/libinput-1.5.0:0=
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}