summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-08 12:11:36 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-08 12:24:50 -0700
commit7d2a1c345f249f7ba6f8f786e3f81662bb0c481c (patch)
tree88df43825f9ced45b5dc802734601f32563e8607 /x11-drivers/xf86-video-amdgpu
parentRevert "x11-drivers/xf86-video-ati: port to EAPI 7" (diff)
downloadgentoo-7d2a1c345f249f7ba6f8f786e3f81662bb0c481c.tar.gz
gentoo-7d2a1c345f249f7ba6f8f786e3f81662bb0c481c.tar.bz2
gentoo-7d2a1c345f249f7ba6f8f786e3f81662bb0c481c.zip
Revert "x11-drivers/xf86-video-amdgpu: port to EAPI 7"
In the port to EAPI=7, we stopped inheriting xorg-2 since that eclass is not EAPI 7 ready. Unfortunately it was providing some critical functionality: [[ ${PN} == xf86-video-* || ${PN} == xf86-input-* ]] && DRIVER="yes" ... xorg-2_flags_setup() { ... [[ ${PN} = xorg-server || -n ${DRIVER} ]] && append-ldflags -Wl,-z,lazy In order to revert this commit, we must revert some commits that fix problems introduced by it as well. In total: This reverts commit 568eca2a556b1f5ba09d5486374cec7346ab1fce. Revert "x11-drivers/xf86-video-amdgpu: add --disable-selective-werror" This reverts commit 66c24d866e939044601f58d1521e00224ca8bf4b. Revert "x11-drivers/xf86-video-amdgpu: fix xorg-server:= dependency" This reverts commit e900d1be730882c962354203277ebb1ba499c0d3. Closes: https://bugs.gentoo.org/661502
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.1-r1.ebuild52
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild51
2 files changed, 11 insertions, 92 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.1-r1.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.1-r1.ebuild
deleted file mode 100644
index 1045c31be890..000000000000
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
-HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-video-amdgpu.git"
- inherit autotools git-r3
- LIVE_DEPEND=">=x11-misc/util-macros-1.18"
-else
- SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-BDEPEND="
- virtual/pkgconfig
-"
-RDEPEND="
- >=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-libs/libpciaccess
- x11-base/xorg-server:=[glamor(-),-minimal]
-"
-DEPEND="
- ${LIVE_DEPEND}
- ${RDEPEND}
-"
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- local econfargs=(
- --disable-selective-werror
- --enable-glamor
- )
-
- econf "${econfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 1045c31be890..90a061997083 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,52 +1,23 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
-DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
-HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-video-amdgpu.git"
- inherit autotools git-r3
- LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
else
- SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-BDEPEND="
- virtual/pkgconfig
-"
-RDEPEND="
- >=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-libs/libpciaccess
- x11-base/xorg-server:=[glamor(-),-minimal]
-"
-DEPEND="
- ${LIVE_DEPEND}
- ${RDEPEND}
-"
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)]"
+DEPEND="${RDEPEND}"
src_configure() {
- local econfargs=(
- --disable-selective-werror
- --enable-glamor
- )
-
- econf "${econfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
+ XORG_CONFIGURE_OPTIONS="--enable-glamor"
+ xorg-2_src_configure
}