summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-16 11:03:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-03-16 11:03:12 +0100
commitea24afe7b6bee7a6b2d29c86e3f872c13098773a (patch)
treeaf9e5ca8b10381d50edd12b6b5e71b7b4e846df4 /x11-drivers/xf86-video-ati
parentsys-fs/cryptsetup: Bump to version 1.7.4 (diff)
downloadgentoo-ea24afe7b6bee7a6b2d29c86e3f872c13098773a.tar.gz
gentoo-ea24afe7b6bee7a6b2d29c86e3f872c13098773a.tar.bz2
gentoo-ea24afe7b6bee7a6b2d29c86e3f872c13098773a.zip
x11-drivers/xf86-video-ati: Bump to version 7.9.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.9.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index 2e31b58c146e..afb0e3a38566 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -3,3 +3,4 @@ DIST xf86-video-ati-7.6.1.tar.bz2 823043 SHA256 2516d9eeb8da8bcd3a01365ed1314919
DIST xf86-video-ati-7.7.0.tar.bz2 836902 SHA256 844d1c577b145c90dc8ef027678f0c27f554363f782cd696a3aea26415b2c1c3 SHA512 002ae681c35c8293d7b11b1fe7ec7fad569a18bcb2091ae54e682de3878ffc681780d802a450f51cf4bcb81a7f137fb6b1c739c467e8f15f4ab8640fb2e472df WHIRLPOOL 69552ee1d715eaf9c0f65da15aa7d0cc1a2a2befe1d8c098b7a8ead11e7201c90b39a9e87811d59026af335532be2da62fe0deb784f8c8c509addcdaf33a5414
DIST xf86-video-ati-7.7.1.tar.bz2 837869 SHA256 00a58588db62ee309095c5c5920bbd248d965e8627f88affe68a73b18865078d SHA512 d8d05b59165cf835231694f190d7fd35d30e28f155d54a537b6ef4c6e60b15099a10d9f2ba4bd13ad9773248a7c3e8099703750129d758cb9c4478ec52d5a1ad WHIRLPOOL 02f8bb7d070042065fdacc4affdb9a1aaef59a827f4feecd590df011e629887a60427ad51d49aa6195118c9520e239e76c393986fb50e8d54afc39ad17c09e72
DIST xf86-video-ati-7.8.0.tar.bz2 845702 SHA256 401f5de772928f3dc4ce43a885adb0a47a2f61aa4a9e45d2ab3d184136a9d6fa SHA512 e09b7aca819656359d32b11f4314f2ad77b7a28d481b2cf17ea62f2e2385f9b40f568d5c76360c800c60c00671f0262277cdefde4c0744f2ed9b3b2fa90a37a9 WHIRLPOOL b5e8a4cf546bb56f1e481e9dc7da8dc850c4fb231d10c592a7e2ffbfb9da0a64edb1b208b326283a6a94e4c0c5aefe5e4a04a984475e7ac5a5bab757ad0f990b
+DIST xf86-video-ati-7.9.0.tar.bz2 848502 SHA256 3cad872e6330afb1707da11e4e959e6887ebe5bcd81854b4d2e496c52c059875 SHA512 125e035da6581520d677c56474653ed75aa6d168bf5450cc973248416b5ada3114ea14d0615b44c58029bb1702609453ab532a506273df2a5dd99dd2af4a9d43 WHIRLPOOL 4aea0ca248c7871c87e82f21ab2325995c86cd49e67e73634544351599912d414250eac9efa77a618bdf232ad2de8ab79c24b339bb0c7797547863a01a6cd72a
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.9.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.9.0.ebuild
new file mode 100644
index 000000000000..a07acc8d9839
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="http://www.x.org/wiki/ati/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.58[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86driproto
+ x11-proto/xproto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}