summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-23 05:50:32 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-23 05:52:19 -0700
commitda600ed2598e9bc35a20c3918522abd516298a2c (patch)
tree805e71c66af0dffa296a9853d73f0185fddb30f7 /x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
parentnet-proxy/shadowsocks-libev: add sub-SLOT dependence. (diff)
downloadgentoo-da600ed2598e9bc35a20c3918522abd516298a2c.tar.gz
gentoo-da600ed2598e9bc35a20c3918522abd516298a2c.tar.bz2
gentoo-da600ed2598e9bc35a20c3918522abd516298a2c.zip
x11-drivers/xf86-video-r128: Version bump to 6.12.0
Closes: https://bugs.gentoo.org/666422 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
new file mode 100644
index 000000000000..2755f0f36f17
--- /dev/null
+++ b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_DRI=dri
+
+inherit flag-o-matic xorg-2
+
+DESCRIPTION="ATI Rage128 video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ )
+}
+
+src_configure() {
+ # always use C11 semantics
+ append-cflags -std=gnu11
+
+ xorg-2_src_configure
+}