summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-02-15 11:40:53 -0800
committerMatt Turner <mattst88@gentoo.org>2018-02-15 11:41:20 -0800
commit0e485e2fcf88a9741484e76d529843665c61719c (patch)
tree785237d8df64b3e81752f828837da1250f747382 /x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild
parentdev-php/PEAR-PEAR_PackageFileManager2: Drop minimal USE (diff)
downloadgentoo-0e485e2fcf88a9741484e76d529843665c61719c.tar.gz
gentoo-0e485e2fcf88a9741484e76d529843665c61719c.tar.bz2
gentoo-0e485e2fcf88a9741484e76d529843665c61719c.zip
x11-drivers/xf86-video-vesa: Version bump to 2.4.0
Diffstat (limited to 'x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild
new file mode 100644
index 000000000000..95de4a3db131
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-info xorg-2
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ >=x11-libs/libpciaccess-0.12.901"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}