summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-23 19:51:30 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-23 19:54:27 -0700
commit5b7f5fc439bdf4ce1d998ba8067259c760fb9ec4 (patch)
treecdb13a040601f7108e6d419d4a91ce328f503101 /x11-drivers
parentx11-libs/libxkbcommon: Version bump to 1.3.1 (diff)
downloadgentoo-5b7f5fc439bdf4ce1d998ba8067259c760fb9ec4.tar.gz
gentoo-5b7f5fc439bdf4ce1d998ba8067259c760fb9ec4.tar.bz2
gentoo-5b7f5fc439bdf4ce1d998ba8067259c760fb9ec4.zip
x11-drivers/xf86-input-libinput: Version bump to 1.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest1
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index 4705655b51e9..1ccf5ad9ef7c 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1 +1,2 @@
DIST xf86-input-libinput-1.1.0.tar.bz2 380727 BLAKE2B 03f394340bb79ee928509471200434fd8efa1385a1747bd1c95743e2d235f806c7b2816496ec74518c18dc967c6761ea779d0c66b525aa80ac6a36bb80c4a45b SHA512 7def9a4834a9203d1672613b1a4b384a0eb3d664818865b375969bf9ca96c512b752859acc8916de9224f7e488f8d59953308e53b983dfa8031ca01fd707fa2b
+DIST xf86-input-libinput-1.2.0.tar.bz2 358985 BLAKE2B f6fc97c4cb81ae61604d2a56063127a5a9a548c529eda9c506a77d8591b9a439cd0fac9c471e7429fddac6e8c4c043087e53d5113ac62c8bdb5b11381f3d5dce SHA512 ebff9490d33fd7495df2e03203060a76b3274f0e638bc92f3d95257fac57cdb9dac308e90e54006fe9522b6de3b1f1c38fd5f0b0b75b7051e5422290f43de52d
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild
new file mode 100644
index 000000000000..23bff0d89282
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/libinput-1.11.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}