summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-17 03:23:40 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-17 03:23:40 +0200
commit9313d7698b2eebdc4412e9f5253d522155d5833d (patch)
tree10b6ead33dde85dd4ef1e3dd0f1e446c36b8e16f /x11-drivers
parentx11-drivers/xf86-input-libinput: Version bump to 0.19.1 (diff)
downloadgentoo-9313d7698b2eebdc4412e9f5253d522155d5833d.tar.gz
gentoo-9313d7698b2eebdc4412e9f5253d522155d5833d.tar.bz2
gentoo-9313d7698b2eebdc4412e9f5253d522155d5833d.zip
x11-drivers/xf86-video-ati: Version bump to 7.7.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.7.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index b4b8a03ed156..6a30c1b3a571 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -2,3 +2,4 @@ DIST xf86-video-ati-6.14.6.tar.bz2 1139495 SHA256 aa5286b3e4f0187d7df14785c06dd8
DIST xf86-video-ati-7.5.0.tar.bz2 809756 SHA256 ec3e6f06b6cf9a40c72aafa3448aae8b034c80b37410ca9442d5cf6806e07936 SHA512 51ea3934285c579314614e336cee0d5c079a466cdc94f2c8649d9499515af3dfb37a7ac87ed69c6dbf6befa5bfca27f8305bbc028ff722e2f87143da5f101f7c WHIRLPOOL ba132708f423cebde7398cc6c9c18334a544ebaef4a60104ea27abeb4afa4a01b9a3dffa00c89e01a6cbf858cc410041d102c8327bc2167ebca5e941d4463f23
DIST xf86-video-ati-7.6.1.tar.bz2 823043 SHA256 2516d9eeb8da8bcd3a01365ed1314919777910fa904ab268af342b5693e1d34c SHA512 b829b1db2088161a2486f396a9b36afd6fbbc765fb495450fb1c2de33951e6270c7ef6665c8275c66dfc6509af71b9882c342d236fc0537ff0dde117683c4891 WHIRLPOOL 91787a77590fbbf30b73fd1c4f7e427ea3eee25b4ba16f52ae2d9d0967b596b33a2bb04bbc8edc83baf48db6cabb459cf81b43da644dd0c1ee415fc650105ffc
DIST xf86-video-ati-7.7.0.tar.bz2 836902 SHA256 844d1c577b145c90dc8ef027678f0c27f554363f782cd696a3aea26415b2c1c3 SHA512 002ae681c35c8293d7b11b1fe7ec7fad569a18bcb2091ae54e682de3878ffc681780d802a450f51cf4bcb81a7f137fb6b1c739c467e8f15f4ab8640fb2e472df WHIRLPOOL 69552ee1d715eaf9c0f65da15aa7d0cc1a2a2befe1d8c098b7a8ead11e7201c90b39a9e87811d59026af335532be2da62fe0deb784f8c8c509addcdaf33a5414
+DIST xf86-video-ati-7.7.1.tar.bz2 837869 SHA256 00a58588db62ee309095c5c5920bbd248d965e8627f88affe68a73b18865078d SHA512 d8d05b59165cf835231694f190d7fd35d30e28f155d54a537b6ef4c6e60b15099a10d9f2ba4bd13ad9773248a7c3e8099703750129d758cb9c4478ec52d5a1ad WHIRLPOOL 02f8bb7d070042065fdacc4affdb9a1aaef59a827f4feecd590df011e629887a60427ad51d49aa6195118c9520e239e76c393986fb50e8d54afc39ad17c09e72
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.1.ebuild
new file mode 100644
index 000000000000..b56347c9c0c1
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="http://www.x.org/wiki/ati/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.58[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86driproto
+ x11-proto/xproto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}