summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-06 13:12:13 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-06 13:14:49 -0700
commitcc7e30f0dc9e095351acb0170c10c199d653c5df (patch)
treeed424628b85fa48c3853bef0fad41fedf4ac632f /x11-drivers
parentdev-libs/wayland-protocols: Drop old versions (diff)
downloadgentoo-cc7e30f0dc9e095351acb0170c10c199d653c5df.tar.gz
gentoo-cc7e30f0dc9e095351acb0170c10c199d653c5df.tar.bz2
gentoo-cc7e30f0dc9e095351acb0170c10c199d653c5df.zip
x11-drivers/xf86-video-intel: Version bump to 20200310
The version bump to 20191209 dropped the GCC workaround patch without explanation, and I only noticed after it was stabilized, necessitating a version bump. Fortunately upstream finally accepted our -fno-common patch, so I can at least get rid of that one. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-intel/Manifest1
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200310.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-intel/Manifest b/x11-drivers/xf86-video-intel/Manifest
index 533a9327ce86..b7836f199b1e 100644
--- a/x11-drivers/xf86-video-intel/Manifest
+++ b/x11-drivers/xf86-video-intel/Manifest
@@ -1,2 +1,3 @@
DIST xf86-video-intel-2.99.917_p20190301.tar.bz2 1247462 BLAKE2B 9047c7a05acaa2125db1527da58d6b4f18d1893e66413facf97b9136adf900cd2b806d149e484880a4361f4798ced52c03ef1b2054136e2896b60aefc3b5e319 SHA512 09ef78d002c6337a2b260999f07c70d9778aa7151f3252c7e2a186b0d1bf218192b616ac8363861e5285dec8fc8599b77eeb1a8195ca5029816f55189aee2b34
DIST xf86-video-intel-2.99.917_p20191209.tar.bz2 1249789 BLAKE2B 69c4772d41283aaf2f635c48448c49f495c2ec443d8ac2ffdb8a3fe68024c31d769bd5d4fdb07cf6150906c44f9562ccb673ac52837fa6be540c61cbc5359ec8 SHA512 a6c9d19736fec794add638731966b8e5841f6b2d81576b5f978b5916cbd4b338aff93ed235c6f284ba86c11cf82a1ebbed2936fdfc539a124c5211436e5ae40c
+DIST xf86-video-intel-2.99.917_p20200310.tar.bz2 1249330 BLAKE2B 7ba7566b946cf2c4ce60170912fe517f8c004a477a0edc2a1a9c4dbc476f3bdbea5b39a3ade4d15854cda2cc1146eca47d5fe8b311dfe36cd5ac39cf390142ea SHA512 764517e2413937ec8486d473e0cb0b98146fbaa2cff15cb01757f2263c29a2fa9279338fc801bdafe4e6b38428f8e771a7ee14fa223ba5711a4369e719258cd0
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200310.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200310.ebuild
new file mode 100644
index 000000000000..c4843a9eaec0
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200310.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DRI=dri
+XORG_EAUTORECONF=yes
+inherit linux-info xorg-3 flag-o-matic
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="amd64 x86"
+ COMMIT_ID="652d93cbbdc159c0883f1b626ea48e28bac63ae3"
+ SRC_URI="https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel/-/archive/${COMMIT_ID}/${P}.tar.bz2"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+DESCRIPTION="X.Org driver for Intel cards"
+
+IUSE="debug +sna tools +udev uxa xvmc"
+
+REQUIRED_USE="
+ || ( sna uxa )
+"
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXScrnSaver
+ >=x11-libs/pixman-0.27.1
+ >=x11-libs/libdrm-2.4.52[video_cards_intel]
+ >=x11-base/xorg-server-1.18
+ tools? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ )
+ udev? (
+ virtual/libudev:=
+ )
+ xvmc? (
+ x11-libs/libXvMC
+ >=x11-libs/libxcb-1.5
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc-pr65873.patch
+)
+
+src_configure() {
+ replace-flags -Os -O2
+ XORG_CONFIGURE_OPTIONS=(
+ --disable-dri1
+ $(use_enable debug)
+ $(use_enable dri)
+ $(use_enable dri dri3)
+ $(usex dri "--with-default-dri=3")
+ $(use_enable sna)
+ $(use_enable tools)
+ $(use_enable udev)
+ $(use_enable uxa)
+ $(use_enable xvmc)
+ )
+ xorg-3_src_configure
+}
+
+pkg_postinst() {
+ if linux_config_exists && \
+ kernel_is -lt 4 3 && ! linux_chkconfig_present DRM_I915_KMS; then
+ echo
+ ewarn "This driver requires KMS support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Graphics support --->"
+ ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
+ ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
+ ewarn " i915 driver"
+ ewarn " [*] Enable modesetting on intel by default"
+ echo
+ fi
+}