summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/agg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/agg')
-rw-r--r--x11-libs/agg/Manifest1
-rw-r--r--x11-libs/agg/agg-2.5-r2.ebuild60
-rw-r--r--x11-libs/agg/files/2.5/02_maintainer_mode.patch21
-rw-r--r--x11-libs/agg/files/2.5/04_no_rpath.patch10
-rw-r--r--x11-libs/agg/metadata.xml11
5 files changed, 103 insertions, 0 deletions
diff --git a/x11-libs/agg/Manifest b/x11-libs/agg/Manifest
new file mode 100644
index 000000000000..6aa79eaa2012
--- /dev/null
+++ b/x11-libs/agg/Manifest
@@ -0,0 +1 @@
+DIST agg-2.5.tar.gz 564313 SHA256 ab1edc54cc32ba51a62ff120d501eecd55fceeedf869b9354e7e13812289911f SHA512 e2c79f0bf6da80e16e5b50e69638647224fbe778a42a83d72e9de444b3ea711735177de92bf16134da313b9f75e63eb76bd7b0aaf390059f4d0785454e8a6fcf WHIRLPOOL aeadbd18d6f5a1af6d10fabe48eaaeabe20c4215c8da4236cb4084a10af59f223814963b43fa01ae280efad2db3789837c0e14a4e43f068a05d1e59739cf996d
diff --git a/x11-libs/agg/agg-2.5-r2.ebuild b/x11-libs/agg/agg-2.5-r2.ebuild
new file mode 100644
index 000000000000..657ccbf158e9
--- /dev/null
+++ b/x11-libs/agg/agg-2.5-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils autotools base
+
+DESCRIPTION="Anti-Grain Geometry - A High Quality Rendering Engine for C++"
+HOMEPAGE="http://antigrain.com/"
+SRC_URI="http://antigrain.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE="+gpc +truetype +X"
+
+# preffer X with enabled xcb, really
+RDEPEND="
+ media-libs/libsdl[X?]
+ X? ( || ( <x11-libs/libX11-1.3.99.901[xcb] >=x11-libs/libX11-1.3.99.901 ) )
+ truetype? ( media-libs/freetype:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+# taken from debian
+PATCHES=(
+ "${FILESDIR}/${PV}/02_maintainer_mode.patch"
+ "${FILESDIR}/${PV}/04_no_rpath.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ sed -r -i \
+ -e 's:^(.*) -L@.*:\1:' \
+ src/platform/X11/Makefile.am || die "Failed to sed"
+ # fix building against automake-1.12, bug 420701
+ sed -i '/^AM_C_PROTOTYPES/d' configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ # examples are not (yet) installed, so do not compile them
+ # sdl is harddep only sdl-tests are optional so we enable them anyway
+ econf \
+ --enable-ctrl \
+ --enable-sdltest \
+ --disable-examples \
+ --disable-dependency-tracking \
+ $(use_enable gpc gpc) \
+ $(use_enable truetype freetype) \
+ $(use_with X x)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc readme authors ChangeLog news
+}
diff --git a/x11-libs/agg/files/2.5/02_maintainer_mode.patch b/x11-libs/agg/files/2.5/02_maintainer_mode.patch
new file mode 100644
index 000000000000..4c65c9723e34
--- /dev/null
+++ b/x11-libs/agg/files/2.5/02_maintainer_mode.patch
@@ -0,0 +1,21 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_maintainer_mode.dpatch by <rodrigo@nul-unu.com>
+##
+## DP: Use AM_MAINTAINER_MODE, to avoid re-running autotools
+## DP: except when explicitely called in debian/rules
+
+@DPATCH@
+diff -urNad agg-2.5+dfsg~/configure.in agg-2.5+dfsg/configure.in
+--- agg-2.5+dfsg~/configure.in 2007-07-21 19:58:06.966030999 -0500
++++ agg-2.5+dfsg/configure.in 2007-07-21 19:58:33.595695250 -0500
+@@ -2,7 +2,7 @@
+ AC_CANONICAL_TARGET
+ AC_CONFIG_HEADERS(include/config.h)
+ AM_INIT_AUTOMAKE(agg, 2.5.0)
+-
++AM_MAINTAINER_MODE
+
+ dnl Checks for programs.
+ AC_PROG_CC
+
diff --git a/x11-libs/agg/files/2.5/04_no_rpath.patch b/x11-libs/agg/files/2.5/04_no_rpath.patch
new file mode 100644
index 000000000000..76582e332738
--- /dev/null
+++ b/x11-libs/agg/files/2.5/04_no_rpath.patch
@@ -0,0 +1,10 @@
+--- agg-2.5.orig/libagg.pc.in 2006-07-10 11:27:16.000000000 +0200
++++ agg-2.5/libagg.pc.in 2006-07-10 11:28:51.000000000 +0200
+@@ -6,5 +6,5 @@
+ Name: libagg
+ Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
+ Version: @VERSION@
+-Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg
++Libs: -L${libdir} -lagg
+ Cflags: -I${includedir}
+
diff --git a/x11-libs/agg/metadata.xml b/x11-libs/agg/metadata.xml
new file mode 100644
index 000000000000..e4e70c77a621
--- /dev/null
+++ b/x11-libs/agg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+</maintainer>
+<use>
+ <flag name="gpc">Enable gpc polygon clipper library</flag>
+</use>
+</pkgmetadata>