summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild')
-rw-r--r--x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild b/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild
new file mode 100644
index 000000000000..b8016311609b
--- /dev/null
+++ b/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="API to access display driver functionality for ATI graphics cards"
+HOMEPAGE="http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/"
+SRC_URI="ADL_SDK${PV/.*/}.zip"
+
+LICENSE="AMD-ADL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="x11-drivers/ati-drivers"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please visit the download page [1], download ${A} and save it in ${DISTDIR}"
+ einfo "[1] http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/"
+}
+
+src_prepare() {
+ sed -i -e '/include/a \#include <wchar.h> \
+#include <stdbool.h>' include/adl_structures.h || die
+}
+
+src_compile() {
+ pushd adlutil
+ $(tc-getCC) main.c ${CFLAGS} -I ../include/ -DLINUX ${LDFLAGS} -o adlutil -ldl || die
+ popd
+}
+
+src_install() {
+ use doc && dodoc -r "Public-Documents"/* "adlutil/ADLUTIL User Guide.doc"
+ use examples && dodoc -r "Sample" "Sample-Managed"
+
+ dobin adlutil/adlutil
+ insinto "/usr/include/ADL"
+ doins include/*
+}