summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-05-21 20:25:05 +0200
committerMatt Turner <mattst88@gentoo.org>2018-05-21 18:05:08 -0700
commit27c5510f6420071fee062901df4061210f329603 (patch)
tree4487fa08d13bb57834ecf804b5c350463c1bcdb0 /x11-libs/dnd/dnd-1.1-r3.ebuild
parentapp-emulation/skopeo: version bump to 0.1.30 (diff)
downloadgentoo-27c5510f6420071fee062901df4061210f329603.tar.gz
gentoo-27c5510f6420071fee062901df4061210f329603.tar.bz2
gentoo-27c5510f6420071fee062901df4061210f329603.zip
x11-libs/dnd: Update x11-proto/xproto dependency to x11-base/xorg-proto and drop it from RDEPEND.
Drop unused inheritance of eutils.eclass.
Diffstat (limited to 'x11-libs/dnd/dnd-1.1-r3.ebuild')
-rw-r--r--x11-libs/dnd/dnd-1.1-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/dnd/dnd-1.1-r3.ebuild b/x11-libs/dnd/dnd-1.1-r3.ebuild
new file mode 100644
index 000000000000..db03f5042758
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm64 ~hppa ~ia64 ~ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/Makefile-fix.patch
+)
+
+S="${WORKDIR}/DND/DNDlib"
+
+src_configure() {
+ tc-export CC CXX RANLIB AR
+ econf --with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+}