summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-30 13:21:53 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-30 13:22:15 +0200
commit106a4fee21c85fb39dfe0c12249ae69a44dc0b47 (patch)
treea7d58d1ae0cab0ff7e8a9669022b050be035435e /x11-libs/fltk
parentx11-libs/fltk: Old (diff)
downloadgentoo-106a4fee21c85fb39dfe0c12249ae69a44dc0b47.tar.gz
gentoo-106a4fee21c85fb39dfe0c12249ae69a44dc0b47.tar.bz2
gentoo-106a4fee21c85fb39dfe0c12249ae69a44dc0b47.zip
x11-libs/fltk: Inject LDFLAGS
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=655246 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/fltk-1.3.5-r1.ebuild3
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild3
-rw-r--r--x11-libs/fltk/fltk-1.4.9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/x11-libs/fltk/fltk-1.3.5-r1.ebuild b/x11-libs/fltk/fltk-1.3.5-r1.ebuild
index edc10f248706..f5bad150013e 100644
--- a/x11-libs/fltk/fltk-1.3.5-r1.ebuild
+++ b/x11-libs/fltk/fltk-1.3.5-r1.ebuild
@@ -118,7 +118,8 @@ multilib_src_configure() {
--enable-xdbe \
--enable-xfixes \
--includedir=${FLTK_INCDIR} \
- --libdir=${FLTK_LIBDIR}
+ --libdir=${FLTK_LIBDIR} \
+ LDFLAGS="${LDFLAGS}"
}
multilib_src_compile() {
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index 68c25259dd95..5750e09a02c7 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -123,7 +123,8 @@ multilib_src_configure() {
--enable-xdbe \
--enable-xfixes \
--includedir=${FLTK_INCDIR} \
- --libdir=${FLTK_LIBDIR}
+ --libdir=${FLTK_LIBDIR} \
+ LDFLAGS="${LDFLAGS}"
}
multilib_src_compile() {
diff --git a/x11-libs/fltk/fltk-1.4.9999.ebuild b/x11-libs/fltk/fltk-1.4.9999.ebuild
index f184108a5c56..6084621d31cb 100644
--- a/x11-libs/fltk/fltk-1.4.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.4.9999.ebuild
@@ -127,7 +127,8 @@ multilib_src_configure() {
--enable-xdbe \
--enable-xfixes \
--includedir=${FLTK_INCDIR} \
- --libdir=${FLTK_LIBDIR}
+ --libdir=${FLTK_LIBDIR} \
+ LDFLAGS="${LDFLAGS}"
}
multilib_src_compile() {