summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/glamor/glamor-0.6.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/glamor/glamor-0.6.0.ebuild')
-rw-r--r--x11-libs/glamor/glamor-0.6.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/glamor/glamor-0.6.0.ebuild b/x11-libs/glamor/glamor-0.6.0.ebuild
new file mode 100644
index 000000000000..f7447da96e00
--- /dev/null
+++ b/x11-libs/glamor/glamor-0.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+XORG_EAUTORECONF=yes
+XORG_MODULE=driver/
+XORG_MODULE_REBUILD=yes
+S=${WORKDIR}/${PN}-egl-${PV}
+
+inherit xorg-2 autotools-utils toolchain-funcs
+
+DESCRIPTION="OpenGL based 2D rendering acceleration library"
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
+
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="gles xv"
+
+RDEPEND=">=x11-base/xorg-server-1.10
+ >=media-libs/mesa-10[egl,gbm]
+ gles? (
+ || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
+ )
+ >=x11-libs/pixman-0.21.8"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-xv-add-missing-include.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable gles glamor-gles2)
+ $(use_enable xv)
+ )
+ xorg-2_src_configure
+}
+
+src_prepare() {
+ sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
+ xorg-2_src_prepare
+ # fail to load grafic driver with hardened compiler #488906
+ if gcc-specs-now ; then
+ append-ldflags -Wl,-z,lazy
+ fi
+}
+
+src_install() {
+ # workaround parallel install failure, bug #488124.
+ autotools-utils_src_install -j1
+}