summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-06 00:05:56 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-06 00:25:54 +0200
commitffad639eebcab36f17613a4af4890182cef88d94 (patch)
tree42f45c558572147e4c2f250a657378c30fc40091 /x11-libs/goffice/goffice-0.10.32.ebuild
parentgnome-extra/libgsf: version bump to 1.14.40 (diff)
downloadgentoo-ffad639eebcab36f17613a4af4890182cef88d94.tar.gz
gentoo-ffad639eebcab36f17613a4af4890182cef88d94.tar.bz2
gentoo-ffad639eebcab36f17613a4af4890182cef88d94.zip
x11-libs/goffice: version bump to 0.10.32
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-libs/goffice/goffice-0.10.32.ebuild')
-rw-r--r--x11-libs/goffice/goffice-0.10.32.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/goffice/goffice-0.10.32.ebuild b/x11-libs/goffice/goffice-0.10.32.ebuild
new file mode 100644
index 000000000000..10ac37730b92
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.32.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.8.7:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}