summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild')
-rw-r--r--x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild b/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..63f8a9431d75
--- /dev/null
+++ b/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GNOME2_LA_PUNT="yes"
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GL extensions for Gtk+ 2.0"
+HOMEPAGE="http://gtkglext.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.3[X,${MULTILIB_USEDEP}]
+ || (
+ >=x11-libs/pangox-compat-0.0.2[${MULTILIB_USEDEP}]
+ <x11-libs/pango-1.31[X,${MULTILIB_USEDEP}]
+ )
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove development knobs, bug #308973
+ sed -i 's:-D\(G.*DISABLE_DEPRECATED\):-D__\1__:g' \
+ examples/Makefile.am examples/Makefile.in \
+ gdk/Makefile.am gdk/Makefile.in \
+ gdk/win32/Makefile.am gdk/win32/Makefile.in \
+ gdk/x11/Makefile.am gdk/x11/Makefile.in \
+ gtk/Makefile.am gtk/Makefile.in \
+ || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS="AUTHORS ChangeLog* NEWS README TODO"
+ einstalldocs
+}