summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-23 20:51:59 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-23 20:52:22 +0200
commit493d89f028d0cd8bcda2998eef2aca6b5bae7c1f (patch)
treec98bf5f226e21a23160e0dac4502ddbbe340b0e0 /x11-libs/gtkglext
parentnet-wireless/bluez: Fix crash with non-LE devices (#655114) (diff)
downloadgentoo-493d89f028d0cd8bcda2998eef2aca6b5bae7c1f.tar.gz
gentoo-493d89f028d0cd8bcda2998eef2aca6b5bae7c1f.tar.bz2
gentoo-493d89f028d0cd8bcda2998eef2aca6b5bae7c1f.zip
x11-libs/gtkglext: Fix build issues (#649718), update ebuild.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-libs/gtkglext')
-rw-r--r--x11-libs/gtkglext/files/gtkglext-1.2.0-gcc8-fixes.patch34
-rw-r--r--x11-libs/gtkglext/gtkglext-1.2.0-r4.ebuild30
2 files changed, 47 insertions, 17 deletions
diff --git a/x11-libs/gtkglext/files/gtkglext-1.2.0-gcc8-fixes.patch b/x11-libs/gtkglext/files/gtkglext-1.2.0-gcc8-fixes.patch
new file mode 100644
index 000000000000..266f5fefc1ed
--- /dev/null
+++ b/x11-libs/gtkglext/files/gtkglext-1.2.0-gcc8-fixes.patch
@@ -0,0 +1,34 @@
+From 1fe275cd7dfa9f3a6db771b0cb945d96787e72cf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ralf=20Cors=C3=A9pius?= <corsepiu@fedoraproject.org>
+Date: Thu, 15 Mar 2018 15:56:20 +0100
+Subject: [PATCH 2/2] GCC-8 fixes.
+
+---
+ gdk/gdkglshapes.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gdk/gdkglshapes.c b/gdk/gdkglshapes.c
+index f72abba..9d1197f 100644
+--- a/gdk/gdkglshapes.c
++++ b/gdk/gdkglshapes.c
+@@ -544,7 +544,7 @@ static GLfloat idata[12][3] =
+ {-Z, -X, 0}
+ };
+
+-static int index[20][3] =
++static int iindex[20][3] =
+ {
+ {0, 4, 1},
+ {0, 9, 4},
+@@ -574,7 +574,7 @@ icosahedron(GLenum shadeType)
+ int i;
+
+ for (i = 19; i >= 0; i--) {
+- drawtriangle(i, idata, index, shadeType);
++ drawtriangle(i, idata, iindex, shadeType);
+ }
+ }
+
+--
+2.14.3
+
diff --git a/x11-libs/gtkglext/gtkglext-1.2.0-r4.ebuild b/x11-libs/gtkglext/gtkglext-1.2.0-r4.ebuild
index 518b12f06ebe..948cc280bb4e 100644
--- a/x11-libs/gtkglext/gtkglext-1.2.0-r4.ebuild
+++ b/x11-libs/gtkglext/gtkglext-1.2.0-r4.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
-GNOME2_LA_PUNT="yes"
+EAPI=6
inherit autotools gnome2 multilib-minimal
DESCRIPTION="GL extensions for Gtk+ 2.0"
@@ -15,35 +13,33 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
>=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
>=x11-libs/pangox-compat-0.0.2[${MULTILIB_USEDEP}]
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
>=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-archive-2014.02.28
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
src_prepare() {
+ # Fix build issues with gcc patch from Fedora, bug #649718
+ eapply "${FILESDIR}"/${P}-gcc8-fixes.patch
+
# Ancient configure.in with broken multilib gl detection (bug #543050)
# Backport some configure updates from upstream git master to fix
- epatch "${FILESDIR}/${P}-gl-configure.patch"
+ eapply "${FILESDIR}/${P}-gl-configure.patch"
+
mv configure.{in,ac} || die "mv failed"
eautoreconf
gnome2_src_prepare
-
- # Remove development knobs, bug #308973
- sed -i 's:-D\(G.*DISABLE_DEPRECATED\):-D__\1__:g' \
- examples/Makefile.am examples/Makefile.in \
- gdk/Makefile.am gdk/Makefile.in \
- gdk/win32/Makefile.am gdk/win32/Makefile.in \
- gdk/x11/Makefile.am gdk/x11/Makefile.in \
- gtk/Makefile.am gtk/Makefile.in \
- || die "sed failed"
}
multilib_src_configure() {