summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-14 14:41:20 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-14 14:46:42 +0200
commit3eccfc8137ada1dc898de1647120918bd9660353 (patch)
tree5b40140e4220c738323bd67c3e79b070651738e8 /x11-libs/gtkhotkey
parentgnome-extra/synapse: Version 0.2.99.4 (diff)
downloadgentoo-3eccfc8137ada1dc898de1647120918bd9660353.tar.gz
gentoo-3eccfc8137ada1dc898de1647120918bd9660353.tar.bz2
gentoo-3eccfc8137ada1dc898de1647120918bd9660353.zip
x11-libs/gtkhotkey: Add USE=static-libs
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs/gtkhotkey')
-rw-r--r--x11-libs/gtkhotkey/gtkhotkey-0.2.1-r1.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/x11-libs/gtkhotkey/gtkhotkey-0.2.1-r1.ebuild b/x11-libs/gtkhotkey/gtkhotkey-0.2.1-r1.ebuild
index c4e3b9053cff..3470b1d217a0 100644
--- a/x11-libs/gtkhotkey/gtkhotkey-0.2.1-r1.ebuild
+++ b/x11-libs/gtkhotkey/gtkhotkey-0.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,24 +18,33 @@ SRC_URI="https://launchpad.net/${PN}/${MY_CRV}/${PV}/+download/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-COMMON_DEPEND=">=dev-libs/glib-2.16
- >=x11-libs/gtk+-2.12:2"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/libintl"
-
-DEPEND="${COMMON_DEPEND}
+IUSE="static-libs"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.12:2
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ virtual/libintl
+"
+DEPEND="
+ ${COMMON_DEPEND}
virtual/pkgconfig
>=dev-util/intltool-0.35.0
- sys-devel/gettext"
+ sys-devel/gettext
+"
PATCHES=( "${FILESDIR}/${P}-glibheaders.patch" )
src_prepare() {
- sed -i -e "s: install-gtkhotkeydocDATA ::" Makefile.in || die "Patching Makefile.in failed"
default
+ sed -i -e "s: install-gtkhotkeydocDATA ::" Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
}
src_install() {