summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-30 21:09:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 15:51:20 +0200
commitd83d6cf66058c521f8c7e7fc53e6acfdd970739f (patch)
tree3eb8afa15d0dee56d586e74166191c04902dd5e5 /x11-libs/gtksourceview
parentmedia-libs/phonon-vlc: Drop 0.11.2 (diff)
downloadgentoo-d83d6cf66058c521f8c7e7fc53e6acfdd970739f.tar.gz
gentoo-d83d6cf66058c521f8c7e7fc53e6acfdd970739f.tar.bz2
gentoo-d83d6cf66058c521f8c7e7fc53e6acfdd970739f.zip
x11-libs/gtksourceview: EAPI-7 bump, drop eutils
The same files are installed in the same locations and tests pass. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild b/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
index 85b4ce8dd568..48c23be47828 100644
--- a/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-2.10.5-r3.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-GNOME_TARBALL_SUFFIX="bz2"
+EAPI=7
-inherit eutils gnome2 virtualx
+GNOME_TARBALL_SUFFIX="bz2"
+inherit gnome2 virtualx
-DESCRIPTION="A text widget implementing syntax highlighting and other features"
+DESCRIPTION="Text widget implementing syntax highlighting and other features"
HOMEPAGE="https://www.gnome.org/"
LICENSE="GPL-2+ LGPL-2.1+"
@@ -21,7 +19,8 @@ RDEPEND="
>=dev-libs/libxml2-2.5:2
>=dev-libs/glib-2.14:2
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
dev-util/gtk-doc-am
>=dev-util/intltool-0.40
@@ -29,19 +28,19 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+DOCS=( AUTHORS ChangeLog HACKING MAINTAINERS NEWS README )
+
+# Patch from 3.x for bug #394925
+PATCHES=( "${FILESDIR}/${P}-G_CONST_RETURN.patch" )
+
src_prepare() {
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ gnome2_src_prepare
# Skip broken test until upstream bug #621383 is solved
sed -i -e "/guess-language/d" tests/test-languagemanager.c || die
# The same for another broken test, upstream bug #631214
sed -i -e "/get-language/d" tests/test-languagemanager.c || die
-
- # Patch from 3.x for bug #394925
- epatch "${FILESDIR}/${P}-G_CONST_RETURN.patch"
-
- gnome2_src_prepare
}
src_configure() {
@@ -49,7 +48,7 @@ src_configure() {
}
src_test() {
- Xemake check
+ virtx emake check
}
src_install() {