summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/guile-gtk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/guile-gtk/files')
-rw-r--r--x11-libs/guile-gtk/files/2.1-brokentest.patch33
-rw-r--r--x11-libs/guile-gtk/files/2.1-prll-install.patch13
-rw-r--r--x11-libs/guile-gtk/files/guile-gtk-2.0-g-object-ref.diff45
3 files changed, 91 insertions, 0 deletions
diff --git a/x11-libs/guile-gtk/files/2.1-brokentest.patch b/x11-libs/guile-gtk/files/2.1-brokentest.patch
new file mode 100644
index 000000000000..ecba95174e0c
--- /dev/null
+++ b/x11-libs/guile-gtk/files/2.1-brokentest.patch
@@ -0,0 +1,33 @@
+diff --git a/tests/gdk.scm b/tests/gdk.scm
+index 6e08f9f..6b01e83 100644
+--- a/tests/gdk.scm
++++ b/tests/gdk.scm
+@@ -1102,28 +1102,6 @@
+ (got (exact-positive-integer? (gdk-screen-height-mm))))
+ (test "gdk-screen-height-mm" #f want got))))
+
+-;;
+-;; gdk-selection-property-get
+-;;
+-
+-(malloced-steady ;; with nothing ever requested
+- (lambda ()
+- (let* ((win sample-win)
+- (want '(#f NONE 0))
+- (got (gdk-selection-property-get win)))
+- (test "gdk-selection-property-get" sample-win want got))))
+-
+-(malloced-steady ;; on a destroyed window
+- (lambda ()
+- (let* ((win (gdk-window-new #f 100 100 '() 'input-output 'toplevel))
+- (want '(#f NONE 0))
+- (got (begin
+- (gdk-window-destroy win)
+- (gdk-selection-property-get win))))
+- ;; final free()s only take place under the main loop, so need this to
+- ;; satisfy `malloced-steady
+- (gtk-main-iteration-do #f)
+- (test "gdk-selection-property-get" (list "destroyed win" win) want got))))
+
+ ;;
+ ;; gdk-text-extents
diff --git a/x11-libs/guile-gtk/files/2.1-prll-install.patch b/x11-libs/guile-gtk/files/2.1-prll-install.patch
new file mode 100644
index 000000000000..b00fc29ca34a
--- /dev/null
+++ b/x11-libs/guile-gtk/files/2.1-prll-install.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+index 822a170..37f43b5 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -72,7 +72,7 @@ gdkdefs = gdk-2.0.defs
+ defsdir = $(datadir)/guile-gtk/
+ defs_DATA = $(gtkdefs) $(gdkdefs)
+
+-install-exec-local:
++install-exec-hook:
+ rm -f $(DESTDIR)$(bindir)/build-guile-gtk
+ rm -f $(DESTDIR)$(bindir)/guile-gtk
+ ln $(DESTDIR)$(bindir)/build-guile-gtk-2.0 $(DESTDIR)$(bindir)/build-guile-gtk
diff --git a/x11-libs/guile-gtk/files/guile-gtk-2.0-g-object-ref.diff b/x11-libs/guile-gtk/files/guile-gtk-2.0-g-object-ref.diff
new file mode 100644
index 000000000000..bd582117f621
--- /dev/null
+++ b/x11-libs/guile-gtk/files/guile-gtk-2.0-g-object-ref.diff
@@ -0,0 +1,45 @@
+--- guile-gtk-2.0.orig/gtk-gl/gdk-gl.defs
++++ guile-gtk-2.0/gtk-gl/gdk-gl.defs
+@@ -22,14 +22,14 @@
+ ;--- Types ... --------------------------------------------------------
+
+ (define-struct GdkGLContext
+- (copy gdk_gl_context_ref)
+- (free gdk_gl_context_unref)
++ (copy g_object_ref)
++ (free g_object_unref)
+ (size "0")
+ (canonical-name "Gdk" "GL" "Context"))
+
+ (define-struct GdkGLPixmap
+- (copy gdk_gl_pixmap_ref)
+- (free gdk_gl_pixmap_unref)
++ (copy g_object_ref)
++ (free g_object_unref)
+ (size "0")
+ (canonical-name "Gdk" "GL" "Pixmap"))
+
+--- guile-gtk-2.0.orig/gtk-gl/gdk-gl-glue.c
++++ guile-gtk-2.0/gtk-gl/gdk-gl-glue.c
+@@ -83,8 +83,8 @@
+
+ sgtk_boxed_info sgtk_gdk_gl_context_info = {
+ { "GdkGLContext", GTK_TYPE_BOXED, NULL },
+- (void *(*)(void*))gdk_gl_context_ref,
+- (void (*)(void*))gdk_gl_context_unref,
++ (void *(*)(void*))g_object_ref,
++ (void (*)(void*))g_object_unref,
+ (void (*)(SCM)) NULL,
+ 0
+ };
+@@ -100,8 +100,8 @@
+
+ sgtk_boxed_info sgtk_gdk_gl_pixmap_info = {
+ { "GdkGLPixmap", GTK_TYPE_BOXED, NULL },
+- (void *(*)(void*))gdk_gl_pixmap_ref,
+- (void (*)(void*))gdk_gl_pixmap_unref,
++ (void *(*)(void*))g_object_ref,
++ (void (*)(void*))g_object_unref,
+ (void (*)(SCM)) NULL,
+ 0
+ };