summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-02-25 21:57:03 -0800
committerMatt Turner <mattst88@gentoo.org>2017-02-25 21:57:03 -0800
commit53b2cb2fb70a0a40a5da4b2e5fe294ab680fbbcd (patch)
tree40a158b471ed1c95196099278fdb8a0bb5dd1f25 /x11-libs/libX11
parentprofiles: Mask glamor and wayland USE flags on m68k and s390. (diff)
downloadgentoo-53b2cb2fb70a0a40a5da4b2e5fe294ab680fbbcd.tar.gz
gentoo-53b2cb2fb70a0a40a5da4b2e5fe294ab680fbbcd.tar.bz2
gentoo-53b2cb2fb70a0a40a5da4b2e5fe294ab680fbbcd.zip
x11-libs/libX11: version bump to 1.6.5.
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.6.5.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index ad85391a43c0..24bf072068bd 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1,3 +1,4 @@
DIST libX11-1.6.2.tar.bz2 2339981 SHA256 2aa027e837231d2eeea90f3a4afe19948a6eb4c8b2bec0241eba7dbc8106bd16 SHA512 c8609ff34d1fe71f35b35e0273a872ccded4d824c8afdcca37e1779d37bf667cb814e0ead0805668b4222f196148476f283e417ba371b722f1fe716a5bbba20b WHIRLPOOL 1e6e5010725586557912ab51aa07c41a6297e26f3818e31cf62d455735f4a4f29c0bd13140964ffb1290588ccb8e1643217bca685aa2e7ec40d99b907541656c
DIST libX11-1.6.3.tar.bz2 2363858 SHA256 cf31a7c39f2f52e8ebd0db95640384e63451f9b014eed2bb7f5de03e8adc8111 SHA512 01bbac8075b3fdae19cacfde1c799469f06fb864235025ce444fc10a3ba079bce30f4f3527db47c5edbf91d08299c61116cdf296efa38b2034c0099fac99cc69 WHIRLPOOL 1aa82b4d00af27e05bd9157cfafe16f2cdeecd3711e983224fda0cf6f323c7165b18f5a4572067b29ff3ca244e91def8523d56fb7be55e977bed507bd5a846f1
DIST libX11-1.6.4.tar.bz2 2340176 SHA256 b7c748be3aa16ec2cbd81edc847e9b6ee03f88143ab270fb59f58a044d34e441 SHA512 1fb2ab1f16af14f03ad147ecf2a43c0137c528b9f7ad7de12c47a5861159313260c40122e8271ebd53bf06636d84a4766e06354c7791780f623ba316bed46e92 WHIRLPOOL 106d0f4cdf6a050c311def3c32dfae344fde7a7147fa6778c228223795e48c3fb8f925ecfe8a38c8b37e0ad88323ec0229dbb11b4dfb841c5466f9068a68caf2
+DIST libX11-1.6.5.tar.bz2 2361556 SHA256 4d3890db2ba225ba8c55ca63c6409c1ebb078a2806de59fb16342768ae63435d SHA512 63c40d37c92b8d1ac78541830b0c624c4e936924b26bce769936e0e2523fa8997be364647705057065f803f804897ea8173d1c41ef69a92832f20cc7c0fd40a0 WHIRLPOOL 0eb876343e64677098a3b40f371ab4af1863641970262c1f2727f2181f6c22937684e1da0896b5318a0ea4ad98f61e228a308c1ee041174d42fbf6a8fc2107b3
diff --git a/x11-libs/libX11/libX11-1.6.5.ebuild b/x11-libs/libX11/libX11-1.6.5.ebuild
new file mode 100644
index 000000000000..501fe24caef7
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.6.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# bogus commit to force manifest regeneration #596462
+
+XORG_DOC=doc
+# needs automake-1.14 without eautoreconf
+XORG_EAUTORECONF=yes
+XORG_MULTILIB=yes
+inherit xorg-2 toolchain-funcs
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6 test"
+
+RDEPEND=">=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-libs/xtrans
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xf86bigfontproto-1.2.0-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/inputproto-2.3[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-aix-pthread.patch
+ "${FILESDIR}"/${PN}-1.1.5-winnt-private.patch
+ "${FILESDIR}"/${PN}-1.1.5-solaris.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ )
+
+ [[ ${CHOST} == *-interix* ]] && export ac_cv_func_poll=no
+ xorg-2_src_configure
+}
+
+multilib_src_compile() {
+ if tc-is-cross-compiler; then
+ # Make sure the build-time tool "makekeys" uses build settings.
+ tc-export_build_env BUILD_CC
+ emake -C src/util \
+ CC="${BUILD_CC}" \
+ CFLAGS="${BUILD_CFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}" \
+ clean all
+ fi
+
+ default
+}