summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-06 15:45:47 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-06 15:45:47 -0700
commit69a1e1d18f271c752e16ce48af9831050469502f (patch)
treefeecf01de5726e1bd25b77fac0636921c6343237 /x11-libs/libX11
parentx11-misc/compose-tables: Version bump to 1.7.2 (diff)
downloadgentoo-69a1e1d18f271c752e16ce48af9831050469502f.tar.gz
gentoo-69a1e1d18f271c752e16ce48af9831050469502f.tar.bz2
gentoo-69a1e1d18f271c752e16ce48af9831050469502f.zip
x11-libs/libX11: Version bump to 1.7.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.7.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 8f1e6329f9f4..7ff1125d796e 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1,2 +1,3 @@
DIST libX11-1.7.0.tar.bz2 2409144 BLAKE2B 1eb6aa8f2fe50ddb2f6d324429b3d9cecfb48833c3f52f22ae8e32846be614c8db63c57d25e2b1c46612b6b333ff61ceab8ac0b605b117bcea1224f918af8e6d SHA512 f661ca90350fd8a94f054b00f12f5122cea068ebff706acfd399462236c189a296a2358d17d16166635101cf56cc19303dd407873a159932d093c9f33556f9fb
DIST libX11-1.7.1.tar.bz2 2426509 BLAKE2B 18db9146f1d1907bccc4c5a48c8d6707b070b8b76703ece1948f53a0307996ba3e538e429df6ea0d9c32f577f9d019ba8a1ae63ab28f840d2c35ee9aa01b6748 SHA512 a76f0a82fce6f9b50646a7cd7ec5ee046650f225816050226068a7548fa083ef07d146d40faaf44e033c59c17b0fda5ffdee3a127dac3ab56cee02133819aa3d
+DIST libX11-1.7.2.tar.bz2 2392982 BLAKE2B ce64bd8172fcf4f5bf0783c4f25f4d220fa0eceb211b7a852802256f7241f543769565f70a59c1ff14e0bb1ae7d3f05914f8f0b1bd423dcb20181cfb2227c70d SHA512 d01e5c1848c76218605e5af2d353de6b301a251555b52a38dbe930e6635d5e8a92d1486eb6d328ad5d42a5939e0d16868ffa19a75e5a7863d1a32e0d0727bdc7
diff --git a/x11-libs/libX11/libX11-1.7.2.ebuild b/x11-libs/libX11/libX11-1.7.2.ebuild
new file mode 100644
index 000000000000..bf033e3cc6be
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ !<x11-base/xorg-proto-2019.2
+ x11-misc/compose-tables"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}